CBR 954RR 2002 - 2003 - CBR 954RR Forum

03- won't stay running..

  #1  
Old 10-12-2017, 12:37 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 4
Default 03- won't stay running..

Had to put in a new head gasket, after I got it back together it would turn over but not start. Could hear fuel pump, put in new spark plugs and fuel pressure regulator. Now it starts but only with full throttle and it doesn't sound right. Now I'm bypassing servo motor- any tips on that? Which postion should the valve in exhaust that the servo controls be in?
 
  #2  
Old 10-12-2017, 12:56 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 8,010
Default

Have you rechecked your cam timing?
 
  #3  
Old 10-19-2017, 06:14 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 4
Default

Thanks to everyone that responded but having a new issue. Ever since i removed the servo motor when i turn the key onto the on position the fan turns on and stays on - (didn't do that before) but now the fuel pump won't prime at all anymore. Was fine when servo was still connected. Even with a servo buddy connected does the same thing. The pump comes when I jump it but then it doesn't shut off.
 
  #4  
Old 10-26-2017, 08:24 AM
Junior Member
Join Date: Feb 2013
Posts: 19
Default

According to the wiring diagram the cooling fan is controlled by the ecm (+ side) and a radiator switch (- side)

If the radiator switch is stuck for some reason, the cooling fan relay would still need to be energised by the ecm, so that's kind of weird. What temp is it reading when you turn on the ignition?

Since your cooling fan is turning on but your fuel pump is not priming, it sounds like you got a sneak path somewhere. Did you fiddle with the wiring or leave some connector disconnected somewhere.

Check all your fuses please.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
forced1(nyc)
CBR 900RR
8
03-13-2010 02:14 PM
jpdixon
CBR 900RR
11
09-30-2009 01:35 PM
DarkWing
CBR 900RR
5
05-24-2009 05:04 PM
Slow
CBR 600F
8
07-28-2008 03:23 PM
PHXf4i
General Tech
5
10-23-2006 10:44 PM


Thread Tools
Search this Thread
Quick Reply: 03- won't stay running..


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.