Shuts off at 6k

  #1  
Old 09-02-2016, 06:36 PM
Jaybird180's Avatar
Senior Member
Thread Starter
Join Date: May 2006
Location: Prince George's County, MD
Posts: 3,471
Default Shuts off at 6k

Bike in shop getting some general maintenance post purchase. I rode it for about a week and it's nice. Except for some TLC from neglect it's a pretty solid purchase.

The tank had some rust in it, which concerned me, the fluids were dark and old and the stock exhaust just had to go!

I had a Jardine RT-1 CF that I picked up for a good price on eBay. The mechanic swapped out the stock air filter for a K&N when he thought it was fruitless trying to clean the stock unit. They attempted to treat the rust in the tank and will have to make a second attempt. They replaced the fuel pump filter sponge, They bolted everything back up and tested it. It tested fine.

Next they were ready to take it on the road and noticed that it would shut off if revved at or above 6k, even when blipping the throttle.

It idles fine and appears to run okay except for the above. It was still on the lift when I got to the shop and I could only see it done once because they had drained the fuel for more troubleshooting by the time I'd arrived.

We're all scratching our heads trying to diagnose it. Suggestions?
 
  #2  
Old 09-02-2016, 09:15 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 7,982
Default

I'm not too familiar with the 1000rr injection system, but I thought that the second set of injectors were there for high rpm performance. Could they be clogged or not firing?

Is there another fuel filter besides what was replaced?

A partially clogged filter will do exactly what you're describing.
 
  #3  
Old 09-02-2016, 09:52 PM
Jaybird180's Avatar
Senior Member
Thread Starter
Join Date: May 2006
Location: Prince George's County, MD
Posts: 3,471
Default

I looked at the microfiche and didn't see any indication of another fuel filter. According to the mechanics description of the upper/lower injectors operation it would seem the upper injectors are clogged but he seems to think the lower injectors would be a more likely culprit. I don't know why..

Mechanic also thinks the rev limiter behavior I described in this thread was a possible warning sign.

He did run seafoam through it as a precaution against clogged fuel system components.
 

Last edited by Jaybird180; 09-03-2016 at 07:56 PM. Reason: Provided link to thread
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
900rrSTUD
CBR 929RR
2
10-06-2008 05:15 PM
ffjoey
CBR 600F
2
04-27-2008 10:11 PM
likwidaudio
General Tech
3
03-20-2007 02:43 AM
rynos
General Tech
1
12-13-2005 11:50 PM


Thread Tools
Search this Thread
Quick Reply: Shuts off at 6k


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.