03 600rr... New clutch wont full disengage. Clutch Hub doesnt spin freely - CBR Forum - Enthusiast forums for Honda CBR Owners

Go Back  CBR Forum - Enthusiast forums for Honda CBR Owners > General > General Tech
Reload this Page >

03 600rr... New clutch wont full disengage. Clutch Hub doesnt spin freely

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.
Sponsored by:
Sponsored by:

03 600rr... New clutch wont full disengage. Clutch Hub doesnt spin freely

Reply

 
 
 
  #1  
Old 05-17-2018, 09:41 PM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 3
Default 03 600rr... New clutch wont full disengage. Clutch Hub doesnt spin freely

Changed the clutch, all was good. Clutch cable was a bit spongy, so I adjusted it out. Ran great for about 3 hrs, clutch was perfect. Guy came to ride it, put it in gear, bike died. Clutch wouldn't disengage. I adjusted the clutch a bit more and it worked... Next day, I went to ride it, had no tension in the cable what so ever. LSS, the the basket nut came loose. It didn't fully come off the spline, but was loose. I tightened it back down, put everything back together, cable is tight, but clutch is not disengaging. I rode it to a shop and it started working a little bit, but not fully disengaging. Sometimes it would but then it'd grab and jerk... I'm sure I'm leaving something out... Help me out. Stretched cable?? Oh has brand new clutch hub, fibers, steels, bolts, springs, and oil. Talk to me...
 
Reply With Quote
  #2  
Old 05-18-2018, 12:54 AM
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 1,524
Default

Hi ,I would suggest re-installing making sure that none of the plates are warped, that the spring and seat judder rings are in the correct position and the proper fibre plate is placed over them, and that the clutch centre nut is staked down,
 
Reply With Quote
  #3  
Old 05-19-2018, 03:09 AM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 3
Default

Originally Posted by CaBaRet View Post
Hi ,I would suggest re-installing making sure that none of the plates are warped, that the spring and seat judder rings are in the correct position and the proper fibre plate is placed over them, and that the clutch centre nut is staked down,
Everything is brand new and nut is staked. I adjusted the cable a bit more today and now its grinding on the clutch cover. The judder rings are the only thing im not sure on. Right now, the are like this(). How should they be(), ((,or )),or )(
 

Last edited by Marr4420; 05-19-2018 at 03:14 AM. Reason: Thought of something relevant to prior statement.
Reply With Quote
  #4  
Old 05-19-2018, 03:42 AM
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 1,524
Default

Like this
 
Attached Thumbnails 03 600rr... New clutch wont full disengage. Clutch Hub doesnt spin freely-judder-fitting.jpg  
Reply With Quote
  #5  
Old 05-20-2018, 08:30 AM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 3
Default

Originally Posted by CaBaRet View Post
Like this
Ohhh, alright. That makes sense of everything. Ill try that out
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ARosario
General Tech
2
04-27-2018 02:36 PM
HeavyCBR
CBR 1000F "Hurricane"
16
12-27-2013 06:57 PM
C Jacob W
F4i - Main Forum
3
07-29-2013 11:03 AM
NYKnick1015
CBR 600F3
19
03-29-2010 08:29 AM
chrisf
CBR 900RR
11
11-11-2006 05:12 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory