F4i - Main Forum Main F4i discussion board

Speedo doesn't go past 180kmph

  #1  
Old 09-25-2016, 02:19 AM
Junior Member
Thread Starter
Join Date: Jan 2016
Posts: 21
Default Speedo doesn't go past 180kmph

I've just discovered my 2002 f4i speedo doesn't go past 180kmph. The bike keeps going past 180 so I don't think it's limited by the ecu. Could it be a speedo problem?
 
  #2  
Old 09-30-2016, 02:55 PM
Senior Member
Join Date: May 2015
Posts: 105
Default

factory speedos do brickwall at a certain speed.

im in metric land and mine wont go over 300
 
  #3  
Old 10-03-2016, 06:32 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,000
Default

Yes thats a speedo problem. The speedo's do not hit a brickwall. They go until you don't. Mine's read 165mph which is what, like 275kph?
 
  #4  
Old 10-03-2016, 06:38 PM
Junior Member
Thread Starter
Join Date: Jan 2016
Posts: 21
Default

Should I try with a new gauge or a new sensor?
 
  #5  
Old 10-04-2016, 04:28 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,000
Default

https://cbrforum.com/forum/f4i-main-...iction-153841/

Looks like its a government reg and will require a different ECU and/or dash. Guess its not broken.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sodahyogesh
F4i - Main Forum
4
12-27-2015 06:52 PM
SpiritRR
CBR 900RR
8
04-28-2008 06:56 PM
drnibor
F4i - Main Forum
26
08-11-2007 07:58 AM
Montyburns
General Tech
10
05-08-2006 01:11 PM


Thread Tools
Search this Thread
Quick Reply: Speedo doesn't go past 180kmph


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.