F4i - Main Forum Main F4i discussion board

HUD stopped working

  #1  
Old 06-17-2009, 07:30 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Posts: 24
Default HUD stopped working

After changing my oil, the HUD no longer works.
The clock still shows the time, brights will light up, along with blinkers....
but everything else including tachometer does not work.

What came lose? I looked around the left side of the bike where a few wires are but i couldn't find anything disconnected.
 
  #2  
Old 06-17-2009, 07:39 PM
Aken's Avatar
July 2008 ROTM
Join Date: Oct 2007
Location: Milwaukee
Posts: 3,002
Default

I still find it amazing that so many of the problems that come up in the F4i section start with the words "after changing my oil". WTF are you people doing?!

Check the wiring harness that comes from the gauges, see if anything pulled loose. If that looks fine, you'll need to track down the ground connection on that harness using a wiring diagram from the owner's manual. If you don't have one give this section a quick search, it's been linked to many times.
 
  #3  
Old 06-17-2009, 07:44 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Posts: 24
Default

yeah i know what you mean lol
found out its just a blown fuse
how did that happen?
 
  #4  
Old 06-17-2009, 07:50 PM
Aken's Avatar
July 2008 ROTM
Join Date: Oct 2007
Location: Milwaukee
Posts: 3,002
Default

There was a short at some point. Maybe you have a frayed wire somewhere?
 
  #5  
Old 06-17-2009, 10:54 PM
ibiggers's Avatar
Senior Member
Join Date: Feb 2009
Location: Naples/Orono Maine
Posts: 168
Default

Well to do your oil you have to take the engine out disconnect everything and pour it out of that cap that says oil right? It's so hard I only do it every 10K or so.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
f2cbr7700
General Tech
2
06-06-2013 01:34 PM
KLO
General Tech
6
11-17-2008 09:01 PM
KLO
CBR 600F4
5
11-16-2008 01:51 PM
93cbr600
CBR 600F2
5
08-04-2007 12:27 PM
Sprocket360
General Tech
0
05-19-2006 03:01 PM


Thread Tools
Search this Thread
Quick Reply: HUD stopped working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.