F4i - Main Forum Main F4i discussion board

Help Won't Start

  #1  
Old 10-06-2010, 04:57 PM
Finch's Avatar
Junior Member
Thread Starter
Join Date: Sep 2010
Location: Greenville, NC
Posts: 10
Default Help Won't Start

Let me start by saying I'm new to owning a bike and don't know a lot about the mechanics yet.

But today i went to go ride and couldnt get it to start.

Initially im getting my display and everything in the on position, but when i go to start it theres a click from somewhere toward the rear and everything shuts down. After that i cant even get a display up for 15 minutes or so.
 
  #2  
Old 10-06-2010, 05:02 PM
Junior Member
Join Date: Sep 2010
Posts: 1
Default

You may want to check your battery, sounds like its needs to be charged
 
  #3  
Old 10-06-2010, 05:08 PM
RdRcr150's Avatar
Junior Member
Join Date: May 2009
Location: Knoxville Tennessee
Posts: 13
Default

Remove seat check battery terminal tightness. If corrosion is present clean terminals. If those are good charge battery.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
supermover25
CBR 600F3
4
03-15-2019 08:14 PM
Freewax
F2 Tech
10
03-05-2011 09:37 PM
zophill
General Tech
8
04-20-2010 07:10 AM
CTcbr929
CBR 600F3
22
07-31-2009 12:25 PM
JayBoCC2
F4i - Main Forum
4
06-23-2009 10:23 PM


Thread Tools
Search this Thread
Quick Reply: Help Won't Start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.