F4i - Main Forum Main F4i discussion board

f4i headlight and fuel pump issue.

  #1  
Old 11-09-2018, 06:22 AM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 11
Default f4i headlight and fuel pump issue.

whats up guys wondering has anyone come across this. basically when ever i have my head lights turned on the fuel pump wont prime.. but when i switch the head lights off the fuel pump primes and the bike starts up no problem. i know there must be a short somewhere in the wires to the lights or could it be in my light swtich or the kill switch? just wondering has anyone had previous experience. also when my lights are shut off and the bike runs it runs fine but the full headlight light on the dash will quickly flicker on and off on and off the quicker i rev and go and when slowing down and stopped doesnt flicker at all. hope someone can help thanks guys
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Noah Sedano
F4i - Main Forum
2
07-05-2018 07:42 PM
tampa_git
F2 Tech
9
01-27-2018 02:05 PM
Fool
F4i - Wanted
3
05-10-2010 02:05 PM
zblad
F4i - Main Forum
3
12-05-2008 01:14 AM


Thread Tools
Search this Thread
Quick Reply: f4i headlight and fuel pump issue.


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.