super blackbird fuel pump not priming - CBR Forum - Enthusiast forums for Honda CBR Owners


CBR 1100XX "Super Blackbird" 1998 - 2003 CBR 1000XX

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-26-2017, 07:38 AM
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 2
Default super blackbird fuel pump not priming

I wonder if anyone can help?. Left blackbird in my garage not started for 3 years when put jump pack on it started but sounded like running on 2 cylinders turned pack off bike stopped. so bought new battery put on now fuel pump not priming no noise when key turns . Looked at fuses and relays all seems ok and bike just turns over as pump not priming .Fi light goes out and hiss key light goes out even tried spare key no joy. Have had bike from new 2000 FI model .Any ideas please guys !!
Reply With Quote
  #2  
Old 10-28-2017, 01:57 AM
Super Moderator
 
Join Date: Oct 2016
Location: Morecambe UK
Posts: 656
Default

Hi , have you tried running a direct feed to the pump to see if it will run independently, could be a lot of dirt in the tank after 3 years, and new petrol could help, check out page 5-58 of the workshop manual
Reply With Quote
  #3  
Old 10-28-2017, 10:21 AM
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 2
Default

Thank you not quite sure about running a direct feed to pump but will try to get some help
Reply With Quote
  #4  
Old 10-28-2017, 11:20 AM
Super Moderator
 
Join Date: Oct 2016
Location: Morecambe UK
Posts: 656
Default

Hi Tim, all you need is good motorcycle wire , and run one from the negative pole of the battery to the Green connector of the pump , and one wire from the Positive pole of the battery to the Brown connector of the pump,take the battery off the bike to do this, but I think after 3 years your going to have to take the pump out to clean it, that could be why your pump isn't priming (blocked up)
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help with relay switch, fuelp pump not priming. heads light not turning on Cmarchandpr F4i - Main Forum 4 06-19-2013 06:04 PM
Fuel Pump not priming decannon04 General Tech 4 05-22-2012 08:49 PM
2001 F4i Electrical Issues - Fuel Pump not priming tmanana General Tech 3 07-12-2009 11:45 PM
fuel pump not priming???? Adrjunkie F4i - Main Forum 9 06-22-2009 08:38 PM
fuel pump not priming....... 03bladeRunneR CBR 954RR 0 03-21-2006 02:47 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 05:14 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.