Help, BIG problem!

  #1  
Old 11-22-2007, 12:36 PM
Thread Starter
Join Date: Nov 2007
Posts: 1
Default Help, BIG problem!

Hey guys, i'm new to bikes....anyway bought a CBR 125 which I love, though I bought it second hand from an official Honda dealer, but it had only done 250 miles so was like new.

I got it today, it started up fine the first few times, but now when I turn it on, nothing happens. NEUTRAL light won't go on, or the indicators, or horn etc. Even when I push the start button to try and turn on the engine, nothing happens.

I pushed the headlight dimmer button and now whenever I turn the bike on (turn the keys to the on position) I just get this hissing sound coming from underneath the seat. I don't know if it's the battery or now (if it's the battery what do I do?)

Anyway, any ideas or help would be much appreciated!

Thx
 
  #2  
Old 12-02-2007, 08:57 PM
Senior Member
Join Date: Jul 2007
Location: Raleigh NC 27603
Posts: 582
Default RE: Help, BIG problem!

i am not familliar with the 125's but is it carberated? and i would take off the seat and check the batt for a charge and also maybe a stupid thing but is it in gear? because somehondas wont turn over if it is in gear and the clutch isnt in
hope it helped
JonBrown
oh and check ur fuses.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kwood
CBR 600F3
1
08-08-2012 11:01 AM
hatchtegman
CBR 900RR
4
09-01-2010 03:15 PM
vietladin
F4i - Main Forum
5
12-25-2007 09:48 AM
dewthedoo05
CBR 1000F "Hurricane"
5
09-04-2007 09:32 PM
Trips
CBR 1000F "Hurricane"
11
11-26-2006 01:45 AM


Thread Tools
Search this Thread
Quick Reply: Help, BIG problem!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.