No lights including dash - CBR Forum - Enthusiast forums for Honda CBR Owners

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.
Sponsored by:
Sponsored by:

No lights including dash

  #1  
Old 02-10-2019, 08:53 AM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 3
Default No lights including dash

I lowsided my 2015 CBR 1000. It start and run but now I have no lights including the instrument cluster help!! And thanks in advance
 
  #2  
Old 02-11-2019, 01:14 PM
tentacleslap's Avatar
Super Moderator
Join Date: Oct 2013
Location: Calgary, Canada
Posts: 446
Default

First step is always to check the battery voltage, and your next stop should be the fusebox. Make sure to check the dash fuses, as it looks like that's where the problem is

With collisions it's always possible that wires have been damaged, especially in the crash area. I'd remove the fairings and give them a good visual. Check for torn insulation or burn marks. Probably a good time to check for hidden crash damage too

Report back once you've done that and we'll try and narrow it down from there
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
2015 CBR 100RR
CBR 1000RR
2
02-15-2019 06:30 AM
xankriz
CBR 600F3
1
04-02-2012 04:02 PM
team honda
North East
0
10-10-2007 11:04 AM
bjtoth1
600 Modifications
5
06-24-2007 02:00 PM


Thread Tools
Search this Thread
Quick Reply: No lights including dash


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.