No lights including dash - CBR Forum - Enthusiast forums for Honda CBR Owners

No lights including dash

  #1  
Old 02-10-2019, 08:48 AM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 3
Default No lights including dash

I Lowside my 2015 CBR 1000. It start and run but now I have no lights including the instrument cluster help!! And thanks in advance
 
  #2  
Old 02-15-2019, 01:59 AM
tentacleslap's Avatar
Super Moderator
Join Date: Oct 2013
Location: Calgary, Canada
Posts: 446
Default

If the bike runs but the dash and lights are off, I'd check the fuses. Also want to check the crash area and handlebars for damaged or broken wires. If that doesn't work, you're probably gonna want to work from a circuit diagram
 
  #3  
Old 02-15-2019, 06:30 AM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 3
Default

Originally Posted by tentacleslap View Post
If the bike runs but the dash and lights are off, I'd check the fuses. Also want to check the crash area and handlebars for damaged or broken wires. If that doesn't work, you're probably gonna want to work from a circuit diagram

thanks I'll check the fuses
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
xankriz
CBR 600F3
1
04-02-2012 04:02 PM
jaynd
Off Topic
29
01-13-2008 08:37 PM
team honda
North East
0
10-10-2007 11:04 AM
bjtoth1
600 Modifications
5
06-24-2007 02:00 PM


Thread Tools
Search this Thread
Quick Reply: No lights including dash


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.