F4i - Main Forum Main F4i discussion board

Speedometer problem

  #1  
Old 06-15-2009, 09:39 PM
Member
Thread Starter
Join Date: Nov 2008
Posts: 32
Default Speedometer problem

For some odd reason when I start the bike, the speedometer is reading like 7mph and when you rev the bike up and pull some rpms the MPH also goes up. Everything else is fine. Except the horn doesn't work now.

Anyone have an idea?

This started AFTER we switched the bent frame for the new one. I can't imagine something is hooked up wrong considering all the plug-ins are different?
 
  #2  
Old 06-16-2009, 12:50 AM
Member
Thread Starter
Join Date: Nov 2008
Posts: 32
Default

Anybody have an idea?
 
  #3  
Old 06-16-2009, 06:07 AM
Member
Join Date: Feb 2009
Posts: 34
Default

What does the speedo do while riding? Do the tachometer, coolant temp, and odometer function correctly?
 
  #4  
Old 06-16-2009, 11:41 AM
Senior Member
Join Date: Jul 2008
Location: NOVA
Posts: 778
Default

It seems there has to be a problem with the speed sensor.
 
  #5  
Old 06-16-2009, 06:10 PM
Member
Thread Starter
Join Date: Nov 2008
Posts: 32
Default

Me < Fail

Once everything was finally put together (chain put on) it cured the problem.

Guess the front sprocket has some free play in it and spins
 
  #6  
Old 06-16-2009, 11:32 PM
Aken's Avatar
July 2008 ROTM
Join Date: Oct 2007
Location: Milwaukee
Posts: 3,002
Default

Originally Posted by Blove1991 View Post
Me < Fail

Once everything was finally put together (chain put on) it cured the problem.

Guess the front sprocket has some free play in it and spins
Yeah there's some centrifugal force or something that allows it to move even in neutral. Try putting your bike on the rear stand and then rev it up - the rear wheel will spin a bit.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Baooo
600 Modifications
10
06-07-2009 10:37 PM
allenpa5
CBR 600F4
1
08-14-2007 01:11 AM
jthompson084
General Tech
3
12-23-2006 02:50 PM
ddaren
F4i - Main Forum
3
10-30-2006 07:55 PM
HAVOC
CBR 600F3
8
08-18-2006 03:03 PM


Thread Tools
Search this Thread
Quick Reply: Speedometer problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.