F4i - Main Forum Main F4i discussion board

My F4i wont start please help fuel pump not priming

  #1  
Old 10-05-2009, 04:37 PM
Senior Member
Thread Starter
Join Date: May 2005
Location:
Posts: 292
Default My F4i wont start please help fuel pump not priming

So after storing my bike outside over the summer it wont start. I had a cover on it and started it twice through out the summer and everything was fine. Then i pulled it out yesterday to change fluids and wash it and it wont start. When the key is on and i go to turn the fuel pump on i hear a click come from the tail and then it clicks again when the fuel pump would stop priming. I checked all fuses and looked everything over but cant figure it out. Any suggestions??
 
  #2  
Old 10-05-2009, 06:47 PM
R Dub's Avatar
October 2011 ROTM
Join Date: Feb 2009
Location: Burbs of Chicago
Posts: 1,340
Default

Does your headlight and cluster light up when the key is on?
 
  #3  
Old 10-06-2009, 02:45 AM
trackjunkie08's Avatar
Junior Member
Join Date: Aug 2009
Posts: 13
Default

Try unplugging and replugging the wire running to your tip sensor mounted on the top of your headlight assembly. i had that cut my fuel relay once after sitting. dunno why but it fixed it.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
C Jacob W
F4i - Main Forum
3
07-29-2013 11:03 AM
aferris54
F4i - Main Forum
21
10-12-2012 10:57 PM
adamw89_2000
F4i - Main Forum
1
08-12-2010 02:18 PM
shok47
F4i - Main Forum
4
05-06-2009 04:41 PM
xxenycejattxx
General Tech
6
10-21-2008 01:35 AM


Thread Tools
Search this Thread
Quick Reply: My F4i wont start please help fuel pump not priming


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.