F4i - Main Forum Main F4i discussion board

FI and Speedo/Odometer wont come on

  #1  
Old 03-12-2012, 09:15 AM
Member
Thread Starter
Join Date: Dec 2010
Posts: 71
Default FI and Speedo/Odometer wont come on

Okay, so long story short, bought an 01 F4i with 11k miles, brand new fairings, yoshi RS-3 Shorty exhaust, had previously been stunted for $800. Runs great and everything, but the FI light does not come on, nor does the Speedo countdown like its supposed to and the odometer doesn't show at all. The Neutral light doesn't come on either because the PO cut the stand/neutral wires at the gear shifter, could that be why they are not coming on?

Any help is appreciated, I will post pics later tonight when I get off of work.
 
  #2  
Old 03-12-2012, 09:19 AM
Member
Thread Starter
Join Date: Dec 2010
Posts: 71
Default

Name:  82f71bb8.jpg
Views: 12
Size:  133.8 KB
Name:  cead5613.jpg
Views: 11
Size:  161.7 KB
Name:  37a8978a.jpg
Views: 12
Size:  160.6 KB
Name:  13f0d969.jpg
Views: 15
Size:  143.7 KB
And just for ****s and giggles, heres my last F4i I owned.
Name:  100_0114.jpg
Views: 11
Size:  134.1 KB
 
  #3  
Old 03-12-2012, 03:39 PM
Senior Member
Join Date: Nov 2011
Posts: 430
Default

I'm not sure why they're not coming on, I'd get the neutral and side stand switches wired back up and check all the harnesses to make sure they're connected good.
 
  #4  
Old 03-12-2012, 11:46 PM
Member
Thread Starter
Join Date: Dec 2010
Posts: 71
Default

Okay, small update. Really looked into tonight and found the culprit. Only thing I have to say is what was the previous owner thinking when they tried to redo the wiring on this bike..

Now, the only problem I have left with this thing is that neither the rear brake or hand lever (front) brake engage the brake light. I have checked the switch for continuity and it checks out good. Where exactly is the switch for the foot break (rear)?
 
  #5  
Old 03-13-2012, 01:09 AM
Senior Member
Join Date: Nov 2011
Posts: 430
Default

The switch should be right by the pedal, there should be 2 springs a return spring and a switch spring which will connect to the switch. Here is a link to the owner's manual and service manual http://www.stephygee.com/f4imanual.zip and here http://www.stephygee.com/2001F4i.zip. They should help you locate it if it's still there.
 
  #6  
Old 03-13-2012, 08:28 AM
Member
Thread Starter
Join Date: Dec 2010
Posts: 71
Default

I'll look at that when I get off work, thank you, now does anyone kno where I can order a front brake switch?
 
  #7  
Old 03-13-2012, 11:28 AM
Senior Member
Join Date: Nov 2011
Posts: 430
Default

You can order one from your local honda dealer or online at places like bikebandit.
 
  #8  
Old 03-13-2012, 09:10 PM
Member
Thread Starter
Join Date: Dec 2010
Posts: 71
Default

The pictures they give in the manual are pretty ****ty and I can't see anything since it's black and white. Anyone have a better picture? Much appreciated!
 
  #9  
Old 03-13-2012, 10:32 PM
Senior Member
Join Date: Nov 2011
Posts: 430
Default

Sorry I don't have one. It's on page 3-25 of the service manual under brake light switch, you can zoom in and look at it better in adobe. It's the only wire that runs right behind the brake pedal, plugs into a black cylinder looking thing that is the switch which can be adjusted to tell the light when to come on.
 
  #10  
Old 03-13-2012, 10:54 PM
Member
Thread Starter
Join Date: Dec 2010
Posts: 71
Default

That picture helps out a little more. Sadly I think the previous owner put on an aftermarket brake lever assembly, so it doens't appear to have a place to hold the sensor as the stock one would. Also, another question, where is the wire that connects to the coolant sensor. mine simply isn't hooked up and I can't find the wire that it goes to to hook it back up. Again, I appreciate the help.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cheech80
General Tech
3
03-18-2009 01:13 PM
Hawk72
F4i - Main Forum
1
10-26-2008 06:00 PM
NY Erion929
CBR 929RR
7
03-19-2008 12:21 AM
noslofivoh
CBR 600F3
0
09-04-2006 03:14 PM
Heaton830
CBR 600F3
9
04-16-2006 07:23 AM


Thread Tools
Search this Thread
Quick Reply: FI and Speedo/Odometer wont come on


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.