Neutral light off/bike starts fine in neutral

  #1  
Old 04-04-2016, 09:39 PM
Thohean's Avatar
Junior Member
Thread Starter
Join Date: Mar 2012
Location: Houston
Posts: 9
Question Neutral light off/bike starts fine in neutral

I have a 2003 600RR. A few months ago I noticed the Neutral light wasn't coming on, but the bike starts fine other than the light not coming on.

I thought I'd have to pull the cluster out and replace the bulb, which was not a project I was looking forward to, so I put it off.

A few days ago I noticed the the neutral light would come on when the key is first turned on when all the other lights come on, but still no light while in neutral. I went ahead and pulled the wire to the neutral switch to see if that would change any of it's behavior and of course, it wouldn't start in neutral without the clutch pulled in, so it seems that the neutral switch is working fine.

What should I test/replace with this kind of issue?

I have a second 2003 600RR as a track bike, so I can pull parts off of it for testing purposes.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
raz478
CBR 600F3
5
11-21-2013 08:49 AM
caddylicious
F4i - Main Forum
22
01-17-2010 12:01 PM
vaggabon
CBR 900RR
7
09-22-2007 10:36 PM
Fee
F4i - Main Forum
4
10-10-2006 09:26 PM


Thread Tools
Search this Thread
Quick Reply: Neutral light off/bike starts fine in neutral


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.