Cbr125r radiator problems

  #1  
Old 07-07-2018, 03:55 AM
Junior Member
Thread Starter
Join Date: Jul 2018
Posts: 2
Default Cbr125r radiator problems

There seems to be a problem with my radiator system as the engine comes really close to overheating before I cut it off, my temperature gauge shows zero meaning cold and the radiator itself is cold, the coolant flowing into the waterpump is cold but it doesn't seem to be circulating. Thermostat is working and there are no blockages, the water pump is also turning so what else could cause this?
 
  #2  
Old 07-07-2018, 04:20 AM
CaBaRet's Avatar
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 2,051
Default

Hi , could be blockage or air lock, have you added coolant lately and did you clear air bubbles
 
  #3  
Old 07-07-2018, 04:23 AM
Junior Member
Thread Starter
Join Date: Jul 2018
Posts: 2
Default

Originally Posted by CaBaRet View Post
Hi , could be blockage or air lock, have you added coolant lately and did you clear air bubbles
I changed coolant recently but there aren't any blockages and no leaks either, I have checked my thermostat and it is fine I am going to try my radiator itself now
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hgdsRaj
New Member Area
8
05-20-2012 03:35 PM
dwellernet
Other Models (125, 250, 400)
1
04-11-2008 04:35 AM
dwellernet
How-To: Mechanical
1
03-03-2008 11:36 AM
Syphen
Sights 'N Sounds
7
09-19-2007 10:36 PM


Thread Tools
Search this Thread
Quick Reply: Cbr125r radiator problems


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.