CBR 150 FI - CODE 12 - Fuel injector

  #1  
Old 04-03-2013, 10:56 AM
Junior Member
Thread Starter
Join Date: Apr 2013
Posts: 6
Default CBR 150 FI - CODE 12 - Fuel injector

Hello guys,

forgive me for posting it here, my bike is not 125 or 250, its 150, but schematics wiring and ecu is almost the same, I hope i can get help here.

History before I encountered problems:

I ordered a thai ecu piggyback , apitech piggyback for my cbr150 ecu, it arrived but with thai manual so cannot understand. I had my friend install it, tapped 3 wires to the ecu pin (7,22,29) but was unsure of wiring colors to tap which is which, he managed to run the bike but is stalling, until it wont start, we gave up and removed the tapped wirings and the piggyback back to stock ecu.

Now my bike wont fire up, I checked and the fuel is very low, we were also trying to fire it up with the tank up, so I thought it just need fuel, we put in 8 liters, still it wont fire up, now we check some things.

1. Spark plug have strong spark
2. After pressing start button for 10 seconds my engine light blinks, 1 long and 2 short, according to cbr 125 and cbr250r this is fuel injector problem, code 12
3. we removed the fuel rail and fuel comes out if we turn the ignition on or press start
4. when turning the key on I hear fuel pump priming and some noise on the injector
5. We followed the troubleshooting procedure of code 12
  • injector connector black and white wire have 12+volts constant when key is on - okay
  • injector connector pink/green wire no continuity to ground(frame) on key off -okay
  • measured injector pins 10ohms(digital multimeter) - standard is 8-16ohms - okay
  • continuity between injector connector pink green to ecu ping green - okay
  • last is replace ecu with good known one- i dont have any friends with this ecu
6. I reset the dtc/mil by removing the ecu for 24 hours- still the same wont start up
7. I reset via shorting the red service slot at the tailight, turn key on, remove short then short again in 5 seconds- still the same
8. checked the grounds, could only find 1 link ot the frame, 4 green wires, they are very good and grounded

So fed up dont know what is wrong we pushed it to honda prestige shop. the mechanic did the following

1. removed the fuel filter, cleaned it up - still no start
2. reset ecu mil/dtc via shorting - nope, I already did that too
3. removed the injector, tried to start it no spray, called honda main mechanic, talk talk
4. after 4 hours told me my injector is broke and i need to order one but would take a month
5. paid him if the diagnosis and pushed my bike home

Now im not sure if its my injector because i have tested ohm pins, it could be my ecu is fried? but its giving me dtc/mil, wirings? i tested the injector connector, I really dont wanna buy uncessary parts

How to know 100% that injector is dead? d0 injectors really go bad as in total no spray? ecu is dead?

sorry for the long post, hope somebody experience the same thing i am experiencing, good thing i have an extra bike to commute to work, but its 2 weeks now and i miss my cbr.

Thanks and regards,
maliken
 
  #2  
Old 04-04-2013, 04:44 AM
Junior Member
Thread Starter
Join Date: Apr 2013
Posts: 6
Default

let me rephrase my question

if the ecu mil/dtc blinks about injectors then it must be the wiring or injectors problem, never the ECU because its blinking

or

if the ecu mil/dtc blinks about injectors it could be the ECU the wiring or injectors

 
  #3  
Old 04-09-2013, 10:50 PM
Junior Member
Thread Starter
Join Date: Apr 2013
Posts: 6
Default

anyone?

if cel says injector its injector?
 
  #4  
Old 04-11-2013, 12:13 PM
Junior Member
Thread Starter
Join Date: Apr 2013
Posts: 6
Default

progress: grounded the injector manually and i can hear the clicks, tried to start while tapping the ground, it started for 2 secs meaning the ecu is not sending signal to the injector to fire, all wirings check out, and im leaning its my ecm

but why the code blinking?

im ready to order a new ecu
 
  #5  
Old 04-13-2013, 07:52 AM
Junior Member
Thread Starter
Join Date: Apr 2013
Posts: 6
Default

so i ordered an ecu, thanks all for the help
 
  #6  
Old 04-16-2013, 02:25 AM
Junior Member
Thread Starter
Join Date: Apr 2013
Posts: 6
Default

problem soved
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
x AtKiiNSoN x
General Tech
0
01-03-2012 12:07 PM
RedWing1
New Member Area
1
08-29-2009 07:50 PM
honda42
General Tech
3
04-16-2009 11:33 PM
RR Riden
General Tech
2
05-30-2007 07:32 PM
RR Riden
General Tech
2
05-30-2007 05:19 PM


Thread Tools
Search this Thread
Quick Reply: CBR 150 FI - CODE 12 - Fuel injector


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.