New Member Area New to CBRForum? Stop in and introduce yourself.

Hi everyone.

  #1  
Old 05-08-2019, 01:02 PM
Junior Member
Thread Starter
Join Date: May 2019
Posts: 3
Default Hi everyone.

I知 new to this hole forum thing and hoping like hell someone can help me. After many years of raising kids I have finally gotten around to buy my high school dream bike. 1999 CBR900RR..
now to get to the point. I have a problem nobody seems to be able to help me with. My bike looses power around 4500rpm only when I知 riding. If I rev in neutral it revs up perfectly. The problem only happens while I知 riding.
I can稚 get her to pass 120kph. I have had the carbs checked and equalized, new plugs, checked the coils and the resistance in the plug leads and made sure the firing order is correct. Compression is fine. I have tested the battery and the rectifier seems faulty as the voltage climbed as a revved up to 5000rpm. Voltage climbed to 18.9V at 5000rpm.
I知 also thinking It could also be a fuel supply problem and thinking to replace the petcock.
Any advice would be greatly appreciated.
David
South Africa
 
  #2  
Old 05-08-2019, 11:38 PM
CaBaRet's Avatar
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 2,345
Default

Yes get that Rec/Reg changed or you will kill your battery, also check stator
 
  #3  
Old 05-09-2019, 12:25 AM
Junior Member
Thread Starter
Join Date: May 2019
Posts: 3
Default

Originally Posted by CaBaRet View Post
Yes get that Rec/Reg changed or you will kill your battery, also check stator
Thank you I ordered a new rectifier and will check the stator. Do you think this is what is causing the bike to Bog when riding?
 
  #4  
Old 05-09-2019, 12:44 AM
CaBaRet's Avatar
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 2,345
Default

Its a very good place to start
 
Attached Files
  #5  
Old 05-12-2019, 07:28 AM
Junior Member
Thread Starter
Join Date: May 2019
Posts: 3
Default Thanks

Just want to thank you for the advise. New rectifier, starter solenoid and battery. Problem solved. Much appreciated
 
  #6  
Old 05-12-2019, 08:43 AM
CaBaRet's Avatar
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 2,345
Default

Well done matey glad you sorted it
 
  #7  
Old Today, 04:54 AM
F4i4ever's Avatar
Member
Join Date: Mar 2016
Location: Ontario
Posts: 39
Default

Hey bud , congrats on getting the kids out to get the baby in lol
I recently did the same thing , about 3 years ago. Love the kids but couldn't wait till they were old enough to get along with out me should any thing happen while I was riding.

Glad you got it sorted out.
Enjoy the ride.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NeonspeedRT
Off Topic
51
11-09-2008 10:02 PM
Off Topic
576
12-28-2007 11:22 AM
stjoetalon
New Member Area
2
11-27-2005 08:42 PM
NeonspeedRT
Off Topic
1
11-25-2004 11:19 PM


Thread Tools
Search this Thread
Quick Reply: Hi everyone.


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.