F4i - Main Forum Main F4i discussion board

Speedometer stops working while riding

  #1  
Old 07-25-2011, 11:43 PM
CBR forever's Avatar
Member
Thread Starter
Join Date: Jul 2011
Location: Oceanside, Ca
Posts: 61
Default Speedometer stops working while riding

My speedometer will work when I start my bike and will work for a while. Then while I'm riding it will stop working, but everything else will work like the rpm gauge. I'll pull over and shut my bike off and start it back up and it will work again. What would cause this?
 
  #2  
Old 07-25-2011, 11:55 PM
Member
Join Date: May 2011
Location: East TN
Posts: 72
Default

Speed sensor maybe? I really don't know for sure, but that would be my guess. Pretty dead here this time of night, so tomorrow you should get some more certain responses.
 
  #3  
Old 07-26-2011, 02:35 AM
DonnyBrago's Avatar
Senior Member
Join Date: Aug 2009
Location: UK
Posts: 377
Default

Originally Posted by CBR forever View Post
My speedometer will work when I start my bike and will work for a while. Then while I'm riding it will stop working, but everything else will work like the rpm gauge. I'll pull over and shut my bike off and start it back up and it will work again. What would cause this?
Almost certainly the speed sensor, however it is a royal pain in the dick to get to. Does the red FI light glow on your clocks when the speedo is playing up? If it does then read the fault code, chances are it will be code 11 IIRC which indicates faulty speed sensor or wiring. Try unplugging the speedo and cleaning out the connections of any grime and corrosion using contact cleaner.

If (when) that doesn't work follow this HOWTO in order to take out the speed sensor and give it a clean, if that doesn't work then replace it.

Donny's speed sensor HOWTO

Had a very similar problem myself, new speed sensor sorted it.
 
  #4  
Old 07-26-2011, 07:10 PM
CBR forever's Avatar
Member
Thread Starter
Join Date: Jul 2011
Location: Oceanside, Ca
Posts: 61
Default

Yeah the red light comes on when the speedo goes out actually I'm going to try that cleaning out.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jaybyrd
General Tech
4
07-09-2010 10:24 AM
dylan
General Tech
6
03-06-2010 06:47 PM
Kuroshio
CBR 600F3
4
09-08-2009 08:42 AM
SlavDog
CBR 900RR
1
08-29-2009 06:47 PM
98CBR600F3
General Tech
6
02-12-2007 12:19 AM


Thread Tools
Search this Thread
Quick Reply: Speedometer stops working while riding


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.