F4i - Main Forum Main F4i discussion board

No taillight, speedo, or tach. Help!

  #1  
Old 11-06-2011, 08:11 PM
jtrisler's Avatar
Member
Thread Starter
Join Date: Oct 2006
Location:
Posts: 33
Default No taillight, speedo, or tach. Help!

Had a really weird problem occur this weekend after I cleaned out a mouse nest from under my seat. Didn't look like he chewed anything back there though and the problem may be unrelated.

My speedometer, taillight, tach, FI light, and Neurtral light are all out. I still have my breaklight, integrated turn signals out back and highbeam light, and clock up front. The bike still fires right up and runs fine.

I'm thinking that it could be a fuse or somehow a chewed wire in the back could effect all this stuff up front since some of my cluster is working.

Any suggestions of what could be the issue.
 
  #2  
Old 11-06-2011, 08:20 PM
96shox's Avatar
Senior Member
Join Date: Sep 2011
Location: Los Angeles
Posts: 219
Default

check all fuses first

then start taking sme bodywork off and looking for chewed wires...mainly behind the gauges. and check for a loose connector
 
  #3  
Old 11-07-2011, 12:07 PM
Senior Member
Join Date: Jan 2010
Posts: 140
Default

Check fuses under front seat. 10a fuse may have blown
 
  #4  
Old 11-07-2011, 05:29 PM
jtrisler's Avatar
Member
Thread Starter
Join Date: Oct 2006
Location:
Posts: 33
Default

All the fuses are good. Took off the windshield, and all the connections seem good and there are no chewed wires. Any other suggestions or could my cluster just have gone bad.
 
  #5  
Old 11-08-2011, 08:14 AM
jtrisler's Avatar
Member
Thread Starter
Join Date: Oct 2006
Location:
Posts: 33
Default

Found it. Went and double checked the fuses and had one fried. Works now. Thanks for the help.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
schemefighter
CBR 600F
6
04-13-2013 01:51 PM
clepies
CBR 600F
0
04-10-2010 02:55 PM
95Cbr6
CBR 600F3
5
01-26-2008 09:10 PM
morfoot
F4i - Main Forum
3
09-10-2007 09:32 AM
matt_m427
F4i - Main Forum
5
01-28-2007 04:02 AM


Thread Tools
Search this Thread
Quick Reply: No taillight, speedo, or tach. Help!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.