Go Back  CBR Forum - Enthusiast forums for Honda CBR Owners > Past CBR Models > CBR 600 F4i > F4i - Main Forum
Reload this Page >

Honda cbr600 f4i FI light stays on but bike starts an runs but runs poorly

F4i - Main Forum Main F4i discussion board

Honda cbr600 f4i FI light stays on but bike starts an runs but runs poorly

  #1  
Old 02-14-2017, 02:43 PM
Junior Member
Thread Starter
Join Date: Feb 2017
Posts: 11
Default Honda cbr600 f4i FI light stays on but bike starts an runs but runs poorly

I have a 2003 honda cbr600 f4i I used to have a problem with the fuel pump it stayed at a constant prime an won't turn off withched caused it to run rich an not want to idle but it would start an run as long as I keep giving it gas an the bike sounds rough when it running .so I got a new ecu for it an it some what fixed the problem now the fuel pump primes an stop like it's supposed to but now every time I start the bike the FI light comes on an stays on it doesn't blink an I feel like the bike is still running the same on the rich side can someone please help
 
  #2  
Old 02-18-2017, 11:47 AM
IDoDirt's Avatar
Retired Super Moderator
Join Date: Aug 2006
Location: South Florida, USA
Posts: 3,187
Default

The FI or MIL (malfunction indicator lamp) will start blinking only with the side stand down and with the engine off, meaning that the bike doesn't start. The Engine Stop switch needs to be in the Run position. Or the engine RPM's need to be below 5000. In any other condition, the MIL will illuminate and stay on. There is a procedure in the service manual for shorting the PGM-FI "service check connector" terminals and then counting the number of blinks of the MIL light.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Moonknight41
General Tech
0
06-22-2016 02:53 PM
rvnkvn
CBR 1000F "Hurricane"
16
01-29-2012 10:56 PM
Jsalty
CBR 600F2
7
08-12-2007 12:49 AM
dragonium25
CBR 600RR
5
09-30-2006 10:51 PM
dragonium25
General Tech
4
09-30-2006 10:50 PM


Thread Tools
Search this Thread
Quick Reply: Honda cbr600 f4i FI light stays on but bike starts an runs but runs poorly


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.