F4i - Main Forum Main F4i discussion board

hey guys need some help please

  #1  
Old 12-16-2009, 06:37 PM
Junior Member
Thread Starter
Join Date: Dec 2009
Location: montgomery,AL
Posts: 6
Default hey guys need some help please

im having a shifting problem on my 02 f4i 14,000 miles sometime its random up or downshift it wont shift to the next gear and doesn't ''click'' into the next gear same thing goes for downshifting and when it wont shift if i engage the clutch again it will shift next time. thanks for the help
 
  #2  
Old 12-16-2009, 09:43 PM
ID_CBRRider's Avatar
Senior Member
Join Date: Jan 2009
Location: Idaho
Posts: 204
Default

Just out of curiousity, have you adjusted your shift lever to where it's comfortable for you?? If it's to high or to low it could cause you to not push, or pull, completly causing inconsistant shifts.

If that's not it then I'd start with a new clutch pack before tearing into the gearbox.
 
  #3  
Old 12-16-2009, 10:16 PM
Aken's Avatar
July 2008 ROTM
Join Date: Oct 2007
Location: Milwaukee
Posts: 3,002
Default

Sounds consistent with missed gears. Adjust the positioning of your shift lever, and be a little more "forceful" (not angry forceful, just a switch click of your foot) when shifting.

If it continues and you really think it shouldn't, look into getting a shift kit. It will replace some of the mechanics with the shifter, and improve the feel and solidity of everything.
 
  #4  
Old 12-16-2009, 10:40 PM
Junior Member
Thread Starter
Join Date: Dec 2009
Location: montgomery,AL
Posts: 6
Default

ok thanks ill give it a try and see what happends
 
  #5  
Old 12-16-2009, 10:50 PM
Incognito's Avatar
Official CBRF Welcome Crew Undercover Agent
Join Date: Oct 2008
Location: Colorado, U.S.A.
Posts: 1,907
Default

Are you modulating the throttle between shifts? There was a guy that had a similar issue as you. Turned out to be a bent piece in the foot pedal linkage which was rubbing on something; real easy fix.
 
  #6  
Old 12-16-2009, 11:03 PM
Junior Member
Thread Starter
Join Date: Dec 2009
Location: montgomery,AL
Posts: 6
Default

ill see if anything is bent i adjusted linkage didnt help. if nothing is bent ill probly try a shift kit it may just be me but idk my other bike didnt do that. r the shift kits hard to install?
 
  #7  
Old 12-16-2009, 11:14 PM
ID_CBRRider's Avatar
Senior Member
Join Date: Jan 2009
Location: Idaho
Posts: 204
Default

Originally Posted by bmwf4i View Post
r the shift kits hard to install?
Harder than making a Peanutbutter and Jelly sandwich, but easier than building a rocket. J/K

They aren't to bad just go step by step, and research everything beforehand so your not going in blind.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
speeddemonx60
Off Topic
10
02-07-2010 11:02 AM
3v1lj03
The Hurricane Saloon
7
05-01-2009 09:59 AM
gotcbr
New Member Area
7
04-29-2009 04:23 PM
Apocal
New Member Area
2
07-23-2007 08:11 AM
acidfire52
CBR 600F2
3
07-17-2007 07:27 PM


Thread Tools
Search this Thread
Quick Reply: hey guys need some help please


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.