F4i - Main Forum Main F4i discussion board

Fuel Pump not cutting on.

  #1  
Old 05-19-2014, 09:56 AM
MissBiBi1's Avatar
Junior Member
Thread Starter
Join Date: Mar 2014
Location: Florida
Posts: 22
Default Fuel Pump not cutting on.

So here is my issue. My bike was working fine; I got the ignition replaced and all. Now when you try to turn on the bike you don't hear the fuel pump sound turn on. All the light work and try to force it on but it won't. One day it did turn on rode it down the street just fine. Turned it off went to the store, then when I cut it back it on I had no issues. Try to leave the parking lot and it shuts off. Then I had the same issue all over again, the fuel pump sound won't come on at all. Any ideas?





I apologize in advanced if I'm not using proper mechanic terms. lol
 
  #2  
Old 05-19-2014, 10:46 AM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 7,872
Default

Things to check:
Headlight on and making good connection
Kill switch contacts clean and in good order
Ignition switch good with proper voltages at each wire
Harness connectors and ecu pins tight and not corroded
Kickstand switch functioning properly
Fuel pump itself
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kopi Ko
F4i - Main Forum
12
11-18-2017 11:46 AM
srp2035
CBR 900RR
1
06-10-2013 09:39 PM
blackwolf17787
CBR 600F3
12
07-04-2011 09:51 PM
zblad
F4i - Main Forum
3
12-05-2008 01:14 AM


Thread Tools
Search this Thread
Quick Reply: Fuel Pump not cutting on.


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.