F4i - Main Forum Main F4i discussion board

Is the fuel pump bad?

  #1  
Old 07-02-2010, 02:44 PM
Junior Member
Thread Starter
Join Date: Jul 2010
Posts: 1
Default Is the fuel pump bad?

Hey Guys...I'm sure that you have all heard this one before over and over again. I have an 02 F4i and it's been literally sitting for about 1 yr. Been busy with work, travel, ect ect...long story...lol...but It's been in storage with little fuel in it and unfortunately the person that was storing it didn't attempt to start it up. But when I left it was freshly serviced. I attempted to bring it back out for riding this year and when I put my new battery in it, the fuel pump isn't priming. Now I've been reading about all this stuff on getting the primer to work but it mainly come from laying the bike down and ect. It's just been sitting so I doubt it's the (Tip Over Sensor) ..could it be the CDI but I don't know how to determine. I turn the key and it's trying...lights are on, blinkers are working it just won't start...It was working perfectly when I left it....I hear a click when I turn the kill switch on but no primer...could it possibly be bad? I'm one to take the bike to the shop but I'm thinking its not that serious...well at least I hope...can anyone help me?....I just wanna ride, weather has been awesome
 
  #2  
Old 07-02-2010, 03:09 PM
Senior Member
Join Date: Mar 2009
Location: Baltimore Maryland
Posts: 901
Default

I guess anything is possible. Did you have some sort of battery tender on it? Even 99% dead battery will still have some juice to work the turn signals and headlight.
 
  #3  
Old 07-02-2010, 04:49 PM
Senior Member
Join Date: Nov 2008
Location: Detroit
Posts: 861
Default

^ He put a "new" battery in it. Try bypassing the BAS, if nothing else just to eliminate it. To bypass it, unplug the harness from the BAS, and hook a jumper wire (a paper clip works) to the outter two wires so that they are connected to each other. Also, you can run a wire from the battery straight to the pump, just to see if it works. You might need a new starter relay. For future reference, don't use the kill switch to shut off the bike, leave it in the run position and use the key to turn off the bike. Since the bike sat for so long, you'll proly need a new FPR too.
Will it crank when you hit the starter button? If not, your motor is hydrolocked (no biggie), and you need to pull the spark plugs out and hit the starter button while the plugs are out to blow all the gas out of the combustion chamber so the valve springs can compress, which would be caused by a bad FPR allowing fuel to pass by into the motor.
Sorry for the long winded novel. Ride safe bro
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kopi Ko
F4i - Main Forum
12
11-18-2017 11:46 AM
Rockshoxtora
General Tech
1
08-12-2010 03:58 PM
Fool
F4i - Wanted
3
05-10-2010 02:05 PM
zblad
F4i - Main Forum
3
12-05-2008 01:14 AM


Thread Tools
Search this Thread
Quick Reply: Is the fuel pump bad?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.