F4i - Main Forum Main F4i discussion board

Brake light not working

  #1  
Old 03-15-2011, 08:37 AM
Senior Member
Thread Starter
Join Date: Sep 2010
Location: Chicago
Posts: 127
Default Brake light not working

I noticed today on the way to work that brake light doesnt light up when i use the front brake. It works fine when i use the back brake and everything else on the bike works fine. I did install crg shorty levers but i dont remember if i ever tested the light after install. When i grab the lever and can hearing the clicking of the switch. What could be making this happen? im 100% sure it worked with the stock lever so im thing it has something to do with that maybe? Thanks
 
  #2  
Old 03-15-2011, 08:47 AM
Banned
Join Date: Nov 2010
Posts: 489
Default

Originally Posted by MuscleswitCBR View Post
I noticed today on the way to work that brake light doesnt light up when i use the front brake. It works fine when i use the back brake and everything else on the bike works fine. I did install crg shorty levers but i dont remember if i ever tested the light after install. When i grab the lever and can hearing the clicking of the switch. What could be making this happen? im 100% sure it worked with the stock lever so im thing it has something to do with that maybe? Thanks
Have you checked the wiring? Maybe something popped out of place....
 
  #3  
Old 03-15-2011, 08:37 PM
Junior Member
Join Date: Mar 2011
Posts: 19
Default

Had the same problem with my bike. I needed to replace the microswitch. Take the microswitch out from the brake and gently apply pressure to it to see if you can get the brake to light up. Mine would light up only if I applied very little pressure. New one ran me $13 at my local bike shop, I'm sure you can find a lot cheaper online if you have the same problem as me.
 
  #4  
Old 03-15-2011, 08:49 PM
hites87's Avatar
Junior Member
Join Date: Nov 2010
Posts: 18
Default

Originally Posted by schnezy View Post
Had the same problem with my bike. I needed to replace the microswitch. Take the microswitch out from the brake and gently apply pressure to it to see if you can get the brake to light up. Mine would light up only if I applied very little pressure. New one ran me $13 at my local bike shop, I'm sure you can find a lot cheaper online if you have the same problem as me.

+1 on the microswitch
 
  #5  
Old 03-15-2011, 09:13 PM
Senior Member
Thread Starter
Join Date: Sep 2010
Location: Chicago
Posts: 127
Default

When I got home I starting looking at it and saw that one of the wires somehow slipped off the clip so I popped it back on and good as new. Hopefully it wont keep falling off. Thanks for the help tho good to know that a microswitch is that cheap I thought for sure that be like another $100 part or something lol.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cuban b
General Tech
3
03-06-2009 06:22 PM
Hayden06F4i
General Tech
11
06-17-2008 09:50 AM
FastHatch
CBR 929RR
6
05-22-2007 03:01 PM
teamdfg
General Tech
5
12-23-2006 03:40 AM
ohg35
General Tech
13
06-22-2006 06:35 PM


Thread Tools
Search this Thread
Quick Reply: Brake light not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.