CBR 600F2 1991 - 1994 CBR 600F2

High speed sluggish

  #1  
Old 08-01-2014, 03:50 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Posts: 12
Default High speed sluggish

Not sure how to explain the problem im having with my f2 but here goes! when riding at high speed " on a track " im only able to just about touch 120mph when its going at this speed it seems to be lacking go go juice! if i shut the throttle off and re open there is a mega delay, also sometimes it seems when the throttle is open that nothing is coming out. Now this only happens when i am reaching over 100mph, the other problem is when i ride her hard she always idles around 2k with a very racey needle if i try and adjust the idle screw she just dies.. i have checked plugs and they seem ok i have recently bought a new set of carbs hoping it is that, am i missing anything else?
 
  #2  
Old 08-01-2014, 03:57 PM
Mattson's Avatar
Retired Super Moderator, Tin Star Man & Hurricane Saloon Prospect, ROTM Feb 2015
Join Date: Sep 2011
Location: Vääksy, Finland
Posts: 2,382
Default

Seems carb related, though I doubt a replacement would be necessary. Have you recently cleaned your carbs? A proper scrub could do the trick, crap in the jets maybe? One thing can be that the petcock isn't opening properly thus letting through just a little gas so when gunning you're starving the carbs. Do you have a fuel filter? Can be clogged .
 
  #3  
Old 08-01-2014, 04:37 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Posts: 12
Default

Originally Posted by Mattson View Post
Seems carb related, though I doubt a replacement would be necessary. Have you recently cleaned your carbs? A proper scrub could do the trick, crap in the jets maybe? One thing can be that the petcock isn't opening properly thus letting through just a little gas so when gunning you're starving the carbs. Do you have a fuel filter? Can be clogged .
i did take my carbs off and gave them a good going over took jets out all clear, i was going to get them syncd but someone had chewwed the syncd screws up so there was no chance of adjusting them, the only fuel filter is the one in the tank and thats clear of anything. Does the petcock oftern have issues on the f2?
 
  #4  
Old 08-01-2014, 04:39 PM
Mattson's Avatar
Retired Super Moderator, Tin Star Man & Hurricane Saloon Prospect, ROTM Feb 2015
Join Date: Sep 2011
Location: Vääksy, Finland
Posts: 2,382
Default

Not often but they are known to fail, the vacuum membrane can rupture however it usually fails to open completely then but I guess anything`s possible...
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
g32bturbo
CBR 600F2
2
02-04-2009 07:35 PM
Coopz
CBR 1000F "Hurricane"
16
11-15-2007 03:55 AM
jchavers_2000
CBR 600RR
65
04-10-2007 04:24 PM
dizzie56
CBR 1000RR
24
08-12-2006 01:38 PM
04CBR600
General Tech
2
06-21-2005 10:16 AM


Thread Tools
Search this Thread
Quick Reply: High speed sluggish


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.