No neutral light,red light stays on and bike wont start

  #1  
Old 01-14-2019, 03:05 AM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 1
Default No neutral light,red light stays on and bike wont start

Hi guys,
Am a new here & thx 4 this great idea.
My 2005 cbr 1000rr recently had overheating issues (upto 114 degrees), but we managed to kinda solve them by checking the thermostat,oil,cleaning the water pipes,checking on the water pump,the wiring 4 the fan & servicing the radiator(overheats to 106 now). We've decided to to install another fan coz the other seems to be weak now (i dont know if it's the right thing to do though). However, the bike has been stressing me again lately, the neutral light got off completely ,the red oil light stays on and the bike wont start! The oil is good & its on level. The battery if fine and the fuel is full. My mechanic has no idea where to start and am getting desperate! What could possibly be the problem? Where should we start looking?...Your replies will be of a HUGE help!...Thx!
 
  #2  
Old 01-15-2019, 09:02 AM
Junior Member
Join Date: Jan 2019
Location: Seattle
Posts: 12
Default

Inspect and test the 'neutral switch.'
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Thohean
CBR 600RR
0
04-04-2016 09:39 PM
dumptransit
CBR 929RR
3
10-31-2008 11:28 AM
sonyab523
F4i - Main Forum
12
06-11-2008 11:15 AM
SVTFire
General Tech
2
08-29-2006 04:18 PM


Thread Tools
Search this Thread
Quick Reply: No neutral light,red light stays on and bike wont start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.