F4i - Main Forum Main F4i discussion board

What did I just pull out of my fuel pump?

  #1  
Old 03-28-2012, 08:38 PM
Junior Member
Thread Starter
Join Date: Mar 2012
Posts: 4
Default What did I just pull out of my fuel pump?

I bought my 01 f4i last year as a rebuilt title (i'm guessing it used to be a stunt bike by various mods and scratches)

But when I tore the bike down for a winter rebuild, this is what I found when I pulled the fuel pump. I'm not completely familiar with the anatomy of bike pumps, i can hold my own under a car, just don't have much hands on experience with bikes.

Name:  70dc298d.jpg
Views: 442
Size:  156.5 KB

so i guess my questions are, what the crap is that, how did it get so tangled, and now that i've yanked it all out, is the pump even going to work anymore? is it safe to try?
 
  #2  
Old 03-28-2012, 09:46 PM
cobra1000rr's Avatar
Senior Member
Join Date: Aug 2011
Location: Indy/Frankfort
Posts: 273
Default

that looks like a dam metal brillo pad or some ****, not sure if that is part of a fuel pump or strainer, is it connected or just stuck up in there?
 
  #3  
Old 03-28-2012, 09:48 PM
Junior Member
Thread Starter
Join Date: Mar 2012
Posts: 4
Default

maybe the guy who owned it before me had a psycho girlfriend who stuffed it in his gas tank.

and it was kind of connected, i couldn't really tell since it was twisted and tangled around it so bad. like i said, i ripped it all off. i'm not yet ready to fire the bike up, but i wanted to know if i should just get a new pump on order or not.
 

Last edited by gotcbr; 03-28-2012 at 09:53 PM.
  #4  
Old 03-28-2012, 09:53 PM
Senior Member
Join Date: Nov 2011
Posts: 430
Default

I guess it's the fuel return filter from looking at a parts diagram and then seeing this CBR 600 F4I FUEL PUMP [55A3] - €100.00 : Bike Breakers, The online shop for Used Motorcycle Parts.
 
  #5  
Old 03-28-2012, 09:55 PM
Member
Join Date: Oct 2011
Posts: 68
Default

mine has that as well, and as far as i know it comes stock? took the pump out and that thing was in there, i also took it out and inspected it thinking the same thing as you. only conclusion i could come up with is to catch in large debris that may clog the small hole into the pump.

i just placed it back in, and made sure it was still covering the little pick up tube.
 
  #6  
Old 03-28-2012, 10:21 PM
Junior Member
Thread Starter
Join Date: Mar 2012
Posts: 4
Default

^sweet, i just did the same and hopefully you just saved me some cash!

on to the next item on the list.. sigh.
 
  #7  
Old 03-28-2012, 10:51 PM
Member
Join Date: Dec 2010
Posts: 71
Default

It's normal, don't freak out. As long as it worked before hand I see no reason why It wouldn't work again.. Put that thing back in there
 
  #8  
Old 03-28-2012, 10:54 PM
cobra1000rr's Avatar
Senior Member
Join Date: Aug 2011
Location: Indy/Frankfort
Posts: 273
Default

wow thats one crazy looking pump filter, never seen that before but i have never pulled the fuel pump either.
 
  #9  
Old 03-28-2012, 11:05 PM
Junior Member
Thread Starter
Join Date: Mar 2012
Posts: 4
Default

back in it goes. you guys rock.
 
  #10  
Old 03-29-2012, 01:03 AM
Junior Member
Join Date: Mar 2012
Posts: 11
Default

yep, just rebuilt my fuel pump about 3 days ago, had the same mess and thought it was a brillo pad myself lol, was just told it was a prefilter so put it back together and worked fine ever since
 

Thread Tools
Search this Thread
Quick Reply: What did I just pull out of my fuel pump?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.