F4i - Main Forum Main F4i discussion board

issue. need some insite

  #1  
Old 04-14-2011, 11:59 AM
Member
Thread Starter
Join Date: Nov 2010
Location: St. Louis, Mo
Posts: 63
Default issue. need some insite

Info of the bike:
04 f4i
21000miles
previous owner rode it hard
has an exhaust that has been cut down (may be stock that they cut down)
The exhaust does have a leak where the pipe meets the headers under the bike
Bike smells rich during idle


here is the issue-
I have had battery issues so i grabbed a new battery about a month ago.
coming home from work two days ago the bike stalled twice each time when i was downshifting to 1st coming to a stop at a red light. I was thinking i just wasnt clutching all the way. (my ride home is only 3 miles and most is highway so i didnt have any other red lights to check)

Drove the bike to work yesterday. leaving work . i get the bike two revs while clutching when i was under the overpass coming to a red light. as i came off the throttle the second flick my bike stalls. fires right back up


ride the few miles down the highway. as soon as i got onto the highway the gas reserve light came on . rode the few miles down the highway and got off to go to the gas station right down the street from my house and the bike stalls again at a red light as im down shifting.

I was able to pop start it and rode it home staying on the throttle the entire time to make sure it didnt stall.

My question is what is causing this?
FPR
low gas
plugs
air filter
charging issues

I have a new k&n air filter just need to put it on
I am going to order these plugs tonight since im sure they have never been changed
Honda CBR600 F4i NGK SPARK PLUG IRIDIUM IMR9A-9H 4 Pack | eBay
 
  #2  
Old 04-14-2011, 12:04 PM
April 2011 Ride of the Month
Join Date: Jul 2009
Posts: 5,692
Default

i vote either charging issue or fpr....
 
  #3  
Old 04-14-2011, 12:23 PM
Member
Thread Starter
Join Date: Nov 2010
Location: St. Louis, Mo
Posts: 63
Default

is there a way for me to check the charging system like you can check an alternator on a car?
 
  #4  
Old 04-14-2011, 03:08 PM
Xander F4i's Avatar
Senior Member
Join Date: Jul 2010
Location: near Brookville, PA
Posts: 513
Default

I've read that they don't really charge under 5,000 rpm.

could be a loose connection on a wiring harness.
 
  #5  
Old 04-14-2011, 03:55 PM
Matt5606's Avatar
Member
Join Date: Apr 2010
Location: Greenwood, NS
Posts: 57
Default

+1 on FPR. Stalling and the smell of gas in the exhaust are tell-tale signs of that goin bad.
 
  #6  
Old 04-14-2011, 04:03 PM
Member
Thread Starter
Join Date: Nov 2010
Location: St. Louis, Mo
Posts: 63
Default

xander-I've herd similar. I find it hard to believe it doesn't start charging until that high rpm.

If it is the fpr is there any way to test it to be positive and where is the best place to buy one.
 
  #7  
Old 04-14-2011, 05:00 PM
Member
Join Date: Mar 2011
Location: Hell
Posts: 68
Default

It actually sounds similar to maybe the regulator rectifier going bad too. i personally had almost the same exact situation only i didn't smell gas at the time. mine simply died most of the times is stopped.
 
  #8  
Old 04-14-2011, 05:15 PM
Sirsabattini's Avatar
Member
Join Date: Mar 2011
Posts: 67
Default

call me a noob here but whats the fpr? lol just curious.

and on my opinion, if it was plugs the bike would either idle like crap, or wouldn't start. i dont think it would be the filter especially if its pretty new. otherwise idk what fpr is so i cant offer an opinion on that one...
 
  #9  
Old 04-14-2011, 05:20 PM
Member
Thread Starter
Join Date: Nov 2010
Location: St. Louis, Mo
Posts: 63
Default

Fpr is fuel pressure regulator.

The bike has the old filter and plugs still. Its idles a little rough but not too bad. Everyone in a while it sounds like it misses once it warms up and the idle rpm drops some.
 
  #10  
Old 04-14-2011, 05:24 PM
Matt5606's Avatar
Member
Join Date: Apr 2010
Location: Greenwood, NS
Posts: 57
Default

FPR is the fuel pressure regulator, and it is attached to the fuel rail. Its supposed to regulate the fuel pressure going to the injectors. Sometimes if they fail, the fuel passes around the diapraghm inside and will leak down into the #2 and 3 cylinders by the small vacuum line attached to it, making the bike run rich.

It doesn't sound like the reg/rec is goin bad cuz he's able to start the bike no probs after it stalls, correct?
 

Thread Tools
Search this Thread
Quick Reply: issue. need some insite


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.