F4i - Main Forum Main F4i discussion board

F4i won't start, not priming, no headlights

  #1  
Old 07-04-2010, 06:12 PM
Member
Thread Starter
Join Date: May 2008
Location: Union, NJ
Posts: 46
Default F4i won't start, not priming, no headlights

Well first hello to everyone. I recently bought an F4i, I've been riding it around the past few weeks no problems. Last night went to eat come out to the bike and the fuel pump won't prime, no clicks from the relay, and the headlight is not on when the ignition is on. Relay,igition, bank sensor? everything seems to be checking out.

I did some voltage and continuity checks, but I'm fairly stumped. I also have a manual that I've been doing some troubleshooting with, just wanted to post up get some help. Thanx
 
  #2  
Old 07-04-2010, 06:38 PM
Member
Join Date: Mar 2009
Location: phoenix for now
Posts: 99
Default

sounds like a problem with the headlight. did you check the connections? if the headlight isnt connected it will kill power to the starter. if its plugged in it could be a bad wire. check continuity to all the wires leading from the headlight
 
  #3  
Old 07-04-2010, 07:06 PM
Member
Thread Starter
Join Date: May 2008
Location: Union, NJ
Posts: 46
Default

yup it's fixed didnt even have a chance to check for any responses.. haha I went back out and started pulling connectors and it was the big one behind the left fairing. It was the pin in the corner with a white wire, it was a bit corroded. So you were def on the right track..

In the interest of not making a new post tho I've had a weird rattling noise coming from the cover for the "alternator"? Thought it was my cam chain getting a little worse but it's something else. It comes and goes sounds similar to a piece of metal or something getting thrown around. No biggie because I'll have the bike serviced soon, just wondering if someone had similar experience. Thanx
 
  #4  
Old 07-05-2010, 07:09 PM
Member
Join Date: Mar 2009
Location: phoenix for now
Posts: 99
Default

if you suspect metal being thrown around in the case, i would def get it serviced asap
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dafizuck
General Tech
2
11-16-2014 04:33 PM
clj016
General Tech
4
06-15-2011 07:47 PM
FLATBLACK740
CBR 900RR
0
06-11-2010 09:33 PM
Turboedsupe
F4i - Main Forum
2
10-06-2009 02:45 AM


Thread Tools
Search this Thread
Quick Reply: F4i won't start, not priming, no headlights


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.