CBR 954RR 2002 - 2003 - CBR 954RR Forum

954 won't start ,no prime,I've checked everything

  #1  
Old 09-25-2017, 07:15 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 6
Default 954 won't start ,no prime,I've checked everything

I am working on my boyfriends 954rr ,it's a 2002 the bike won't start the fuel pump won't Prime and I've checked everything from the fuses the relays the ignition switch Bank angle sensor I tested the fuel pump and it it works when I run a directly to the battery so I hooked it up on a toggle switch check the spark plugs ECU and nothing I'm confused and frustrated help please help
 
  #2  
Old 09-25-2017, 09:05 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 7,684
Default

Did you check for 9v on the pink wire on the ignition switch?
 
  #3  
Old 09-26-2017, 12:44 AM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 6
Default Still nothing

Originally Posted by 74demon View Post
Did you check for 9v on the pink wire on the ignition switch?
yes and the diode in the switch is good ,I just got done checking and cleaning the injectors and still nothing
 
  #4  
Old 09-26-2017, 08:53 AM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 7,684
Default

The engine is cranking, correct?
 
  #5  
Old 09-26-2017, 09:39 AM
Gambeno82's Avatar
Junior Member
Join Date: Sep 2017
Location: McDonough, Georgia
Posts: 19
Default

So all your lights are on but when but when you turn the key nothing happens??... right.. have you checked the starter? ..... is it clicking like it want to turn over?
 
  #6  
Old 09-26-2017, 09:40 AM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 6
Default

Originally Posted by 74demon View Post
The engine is cranking, correct?
yes but it won't turn over
 
  #7  
Old 09-26-2017, 09:45 AM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 6
Default

Originally Posted by Gambeno82 View Post
So all your lights are on but when but when you turn the key nothing happens??... right.. have you checked the starter? ..... is it clicking like it want to turn over?
yes all the lights are on ,the only thing is the fuel pump won't prime so I ran it sraight to the battery on a toggle ,and also the power comander won't work on the bike anymore ,but it gets power when I hook it to my laptop so I know that the power comander is still good.
 
  #8  
Old 09-26-2017, 11:01 AM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 7,684
Default

Originally Posted by Poptart99 View Post
yes but it won't turn over
Cranking and turning over are the same thing. Which is it?
 
  #9  
Old 09-26-2017, 11:07 AM
CaBaRet's Avatar
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 2,054
Default

Is your 20amp PGM-fi fuse intact
 
  #10  
Old 09-26-2017, 01:33 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 6
Default

Yes
 

Thread Tools
Search this Thread
Quick Reply: 954 won't start ,no prime,I've checked everything


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.