F4i - Main Forum Main F4i discussion board

gas smell from exhaust

  #1  
Old 09-03-2015, 07:17 AM
Senior Member
Thread Starter
Join Date: Jun 2012
Location: Montgomery, Alabama
Posts: 143
Default gas smell from exhaust

hey everyone, i bought a 03 f4i babout 3 years ago and ever since ive bought it, it has a strong gas smell from the exhaust, its stock other than air filter and exhaust. i have changed fpr and spark plugs to no avail, how can i get this smell gone
 
  #2  
Old 09-03-2015, 08:09 AM
Mattson's Avatar
Retired Super Moderator, Tin Star Man & Hurricane Saloon Prospect, ROTM Feb 2015
Join Date: Sep 2011
Location: Vääksy, Finland
Posts: 2,382
Default

Have you gotten it dynoed? It could be running very rich if someone had fiddled with the maps before you. Does it go pop at motor braking, hard to start while cold out, what did the old plugs look like? Faulty injector maybe?
 
  #3  
Old 09-03-2015, 08:12 AM
Senior Member
Thread Starter
Join Date: Jun 2012
Location: Montgomery, Alabama
Posts: 143
Default

no i havent gotten it dynoed, it doesnt have a power commander or any kind of programmer. it does backfire a tad bit if im at very high rpms and then let it come down but its rare. the old plugs were black and def needed changing. how could i check the injector without just replacing it
 
  #4  
Old 09-03-2015, 08:15 AM
Mattson's Avatar
Retired Super Moderator, Tin Star Man & Hurricane Saloon Prospect, ROTM Feb 2015
Join Date: Sep 2011
Location: Vääksy, Finland
Posts: 2,382
Default

In a nutshell, I'd search for a more thorough explanation prior trying but: Pop em out, put them in individual cups, plug them in, attempt to start for a while, cross-measure fluid in cups. If one is emptier or fuller than others U got a bad squirt.
 
  #5  
Old 09-03-2015, 09:25 AM
Senior Member
Thread Starter
Join Date: Jun 2012
Location: Montgomery, Alabama
Posts: 143
Default

wow, thats actually freakin genius lmao ive never thought of doing that. thanks man.
 
  #6  
Old 09-03-2015, 10:24 AM
Senior Member
Join Date: Aug 2011
Location: So Cal
Posts: 379
Default

Somewhat similar situation that I have with my 02 which began after I installed a Yoshi exhaust (no power commander). Runs strong with no pops and has been that way now for going on three years with average 35-40 mpg. My thoughts, which may or may not be correct, is that the loss of back pressure causes a rich idle due to the eci not being able to compensate at idle range rpm.
 
  #7  
Old 09-04-2015, 02:22 PM
Senior Member
Thread Starter
Join Date: Jun 2012
Location: Montgomery, Alabama
Posts: 143
Default

probably so :-\ i need to purchase a power commander as much as i dont want to, because when i but power commando ill have to get new exhaust to get a map from the website
 
  #8  
Old 09-04-2015, 06:22 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,024
Default

I've had my slip on for 40,000 miles of the bikes life now with no other mods and never had a large gas smell. Something else is off on your bike.
 
  #9  
Old 03-19-2016, 02:33 PM
Senior Member
Thread Starter
Join Date: Jun 2012
Location: Montgomery, Alabama
Posts: 143
Default

still having this issue..could really use some help to get it resolved... cant figure out what it is
 
  #10  
Old 03-24-2016, 02:35 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,024
Default

Might be worth it to pay a shop to diag it for you.
 

Thread Tools
Search this Thread
Quick Reply: gas smell from exhaust


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.