F4i - Main Forum Main F4i discussion board

bike turned off mid ride? fuel issue?

  #1  
Old 09-04-2015, 07:31 PM
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Austin, TX
Posts: 188
Default bike turned off mid ride? fuel issue?

so i was riding down the highway when the FI light turned on and off repeatedly seemed like i was losing gas than gaining power than losing gas than the bike lost all power(engine still on) pulled to the side than the bike turned off when at complete stop, verified fuel relay couldn't be that its bypassed, check bank tilt sensor couldn't be that cause thats bypassed, opened killswitch and nothing wrong there i see the FI sign come on for a millisecond but the light is very very dim, any ideas????

speed demon you out there to help jaja?
 
  #2  
Old 09-04-2015, 07:37 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 8,005
Default

Dim light? Is the battery low? Fi bikes don't run on low voltage very well.
 
  #3  
Old 09-04-2015, 07:39 PM
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Austin, TX
Posts: 188
Default

bikes turns over so easily i don't hear the fuel pump kick on at all, headlights turn on no loss of power also i checked connection to fuel pump nothing wrong there...lost
 
  #4  
Old 09-04-2015, 07:47 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 8,005
Default

Did you verify that the bypasses are still bypassed?

Fi fuse intact?
 
  #5  
Old 09-04-2015, 07:48 PM
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Austin, TX
Posts: 188
Default

yes all of them are still bypassed, where is that fi fuse? if its where the rest of the fuses are than yes they were all good when pulled out
 
  #6  
Old 09-04-2015, 07:57 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 8,005
Default

Is there power at the fuel pump?
 
  #7  
Old 09-04-2015, 07:58 PM
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Austin, TX
Posts: 188
Default

how do i verify that
 
  #8  
Old 09-04-2015, 07:59 PM
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Austin, TX
Posts: 188
Default

also tks for replying so fast
 
  #9  
Old 09-04-2015, 08:02 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 8,005
Default

Voltmeter or test light.

Do you have a manual with a wiring diagram?
 
  #10  
Old 09-04-2015, 08:07 PM
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Austin, TX
Posts: 188
Default

nope :/
 

Thread Tools
Search this Thread
Quick Reply: bike turned off mid ride? fuel issue?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.