F4i - Main Forum Main F4i discussion board

01 F4i keeps blowing starter relays

  #1  
Old 08-16-2018, 07:49 AM
Junior Member
Thread Starter
Join Date: Nov 2017
Posts: 11
Default 01 F4i keeps blowing starter relays

G'day,
I my F4i keeps blowing starter relays, 2 so far. Not sure the origins of the first starter relay, when it blew it i had to replace the plug from the wiring harness because it was melted so badly.
The 2nd starter relay was a cheapy from China (it came with the 15amp fuse, not sure why).

My mechanic thought it might be the regulator/rectifier but did a voltage test while the bike was running and was getting between 13.7 and 14.5 (no higher).
Note: Bike has been made into a stunt bike buy the previous owner with a few extra electronic bits... jet ski kill switch, speedo healer, fans on a switch.

Any insights would be appreciated

 

Last edited by donkeyf4i; 08-16-2018 at 07:55 AM.
  #2  
Old 08-16-2018, 10:37 AM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 7,684
Default

Check your cable resistances, starter draw, and grounding points on the battery cable. Resistance causes heat. Everything in the circuit can take more heat than that little spot.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Cobretticuz
F4i - Main Forum
5
06-23-2011 02:53 PM
Xuracing
F4i - Main Forum
2
04-22-2009 12:11 PM
njdjh2o
CBR 600F3
9
06-11-2008 06:02 PM
bgray
F4i - Main Forum
1
08-29-2005 01:46 PM


Thread Tools
Search this Thread
Quick Reply: 01 F4i keeps blowing starter relays


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.