CBR 954RR 2002 - 2003 - CBR 954RR Forum

954rr3 wont fire

  #1  
Old 03-16-2014, 02:29 AM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 7
Default 954rr3 wont fire

Hi all.
I bought an 03 954rr last year and it has been running great until last week. After a good ride I pulled into a gas station and filled up but when I turned the ignition on the display came on as normal but I couldnt hear the fuel pump prime. I then tried to start it but nothing would happen.
I checked all the fuses and they looked ok. While I was waiting for the tow truck I tried it a few more times and all of a sudden I heard the fuel pump kick in and she then started ok. Home I went great.
I tried starting it about a week later( bike was left on trickle charge so battery was full up) and I can hear the fuel pump prime but she wont fire. The starter motor is turning over but no joy.
Im no expert and I have some mechanical knowledge aided by my Dad but my logic says it could be a fuel flow problem.
Does anybody know if it is likely to be the fuel pump that is faulty or are they generally reliable?
Any help would be very grateful
 
  #2  
Old 03-17-2014, 03:59 AM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 7
Default

oh and it definetly has a spark at the plugs but just wont fire.
Did fuel flow test according to manuel and its about half of what its supposed to be, Im thinking fuel pump problem.
Just linked out the diagnostic plug and im getting a constant fast flash at about 2 second intervals, cant find the meaning of this on my mauel though.
Any ideas guys?
 
  #3  
Old 03-17-2014, 08:50 AM
Conrice's Avatar
Retired Super Moderator and Fighterer
Join Date: Nov 2006
Posts: 6,148
Default

Originally Posted by Andrewsblade View Post
oh and it definetly has a spark at the plugs but just wont fire.
Did fuel flow test according to manuel and its about half of what its supposed to be, Im thinking fuel pump problem.
Just linked out the diagnostic plug and im getting a constant fast flash at about 2 second intervals, cant find the meaning of this on my mauel though.
Any ideas guys?
Faulty FPR? If it's letting the pressure off quicker, it'll lower the fuel flow.

I'm not really sure though. When you turn the ignition on, you hear your fuel pump priming, right? How long does it prime for? Does it continually run?


You're 100% you have spark?
 
  #4  
Old 03-17-2014, 09:20 AM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 8,010
Default

I had the little hose that connects the fuel pump to the filter go bad on me before. It bled off fuel and pressure inside the tank. There are 2 rubber hoses on the module that could leak. Check and see if the filter is plugged if you go in there. If the pump runs, it's working. It's not usually going to lose pressure and still pump.
 
  #5  
Old 03-18-2014, 04:53 PM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 7
Default

Thanks for your reply guys. I thought ide try to start it this morning and gave it some throttle same time. It took a little time cranking over but then she fired. Left it warm up until fan kicked in and turned it off. Started ok a few times after aswell.
So it looks like fuel pump must be ok and definitely plugs sparking.
Is it possible I might have flooded the engine as I did start it up midweek before she totally stopped working? I ask the question as I only ran it for about 15 secs and I know it runs at higher revs for a short while first.
Im going to leave it overnight and try it again in the morning.
When it first didnt start in the gas station there was a datatool alarm system fitted to it. I have since taken that off so was wondering if the alarm was faulty could it have caused the fuel pump not to prime then suddenly kick in after?
Thanks for your time and ile update this post soon
 
  #6  
Old 03-18-2014, 06:35 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 8,010
Default

was wondering if the alarm was faulty could it have caused the fuel pump not to prime

Sure it can. Aftermarket electronics are very suspect when electrical gremlins occur. When I'm tracing electrical problems, it usually ends up being something non-factory or something that someone has touched/disturbed.
 
  #7  
Old 03-19-2014, 04:51 PM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 7
Default

Glad that alarm is gone now 74Demon. I think they are more trouble than they are worth.
As I said The bike is starting good now BUT, lol. I think I still have a problem.
I can hear a loud knocking noise from the engine. When I start it from cold I cant hear it much but when the revs drop down to normal idle speed there's a definitive loud knocking from the engine.
Ive not noticed this before and I definitely haven't adjusted anything looking for the starting problem.
Ive watched a few video's on YouTube and there are a few videos showing same bike with same loud knocking noise. Unfortunately they dont seem to know what it is either.
Im a bit reluctant to use her now as im not sure if I will damage her.
Any ideas what it could be?
 
  #8  
Old 03-19-2014, 06:02 PM
74demon's Avatar
Administrator and MVN, March 2012/Oct 2013 ROTM
Join Date: Sep 2011
Location: socal 949/951
Posts: 8,010
Default

Hard to advise you on the knocking noise without hearing it. What I can say is that these motors tend to be a little rattly anyway. Hopefully nothing catastrophic is happening to it.
 
  #9  
Old 03-19-2014, 06:21 PM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 7
Default

Ok thanks for your help anyway
 
  #10  
Old 03-19-2014, 09:38 PM
Conrice's Avatar
Retired Super Moderator and Fighterer
Join Date: Nov 2006
Posts: 6,148
Default

Stethoscope it out and see where it's coming from.
 

Thread Tools
Search this Thread
Quick Reply: 954rr3 wont fire


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.