F4i - Main Forum Main F4i discussion board

Wiring diagram is wrong? Or is my harness the issue?

  #1  
Old 11-27-2017, 04:25 PM
Junior Member
Thread Starter
Join Date: Nov 2017
Posts: 3
Default Wiring diagram is wrong? Or is my harness the issue?

Hey guys I have just picked up an 02 f4i and I'm not gonna lie this wiring is CHOPPED. Almost makes me regret buying it once I realized what a peice this thing was, didn't quite realize the extent of work this thing needed but oh well, I'm $500 into maintenance and I got what I asked for. Can't turn back now, this is what happens when you buy the cheapest f4i on Craigslist. I have a ridiculous amount of paint and bondo work to do on top of it.

Enough ranting about my purchase, basically on the wiring diagram for the turn signal relay, you will see that our bikes call for a 2 pin relay on a 3 pin connector. There is a gray wire and a whitegreen wire going to it ON THE DIAGRAM. My issue is that I have the whitegreen and gray wires, but I also have a wire that is solid green, aka the ground for these bikes. Why do I have an extra ground? I know I'm not crazy, the blinkers only begin to turn on when I hook that connector up to a relay. What is going on? Look all the way bottom left for the turn signal relay.
 
  #2  
Old 11-27-2017, 06:36 PM
Junior Member
Thread Starter
Join Date: Nov 2017
Posts: 3
Default

when i hook up all 4 corners on the harness to leds (i know this should cause it to blink fast on a regular relay) to a 3 pin relay (i dont have the oem relay, again, bike is seriously chopped to hell) i dont get a fast blink i just get a steady light. trying to figure out what is wrong and how this extra ground wire might play into it.
 
  #3  
Old 11-27-2017, 07:27 PM
CaBaRet's Avatar
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 2,050
Default

Hi have a look at this 2 pin for use with led, and explanation given
LED Turn Signal Flash Rate Relay CBR 600 F2 F3 F4 F4I 929RR 954RR Turn Resistor | eBay
 
  #4  
Old 11-27-2017, 07:35 PM
Junior Member
Thread Starter
Join Date: Nov 2017
Posts: 3
Default

so the ground is not always needed for all relays? im using a flasher off a 95 corolla, ill probably get 1 made for leds like you posted or just add some resistors. im just trying to figure out why my bike is differing from the diagram, making me question what is real?
 
  #5  
Old 11-27-2017, 08:07 PM
CaBaRet's Avatar
Super Moderator
Join Date: Oct 2016
Location: UK
Posts: 2,050
Default

Originally Posted by D3310n View Post
so the ground is not always needed for all relays? im using a flasher off a 95 corolla, ill probably get 1 made for leds like you posted or just add some resistors. im just trying to figure out why my bike is differing from the diagram, making me question what is real?
Basically they can be 2 pin and 3 pin , the White/Green and the Grey wires are circuit wires (white/green going to the fuse box) and the Green wire is Earth, the relay on Ebay is 2 pin but should sort out the problem but may need hard wiring
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JMoore84
F2 Tech
0
03-09-2011 05:38 PM
amRRussel
F2 Tech
9
09-06-2010 12:56 AM
adamw89_2000
F4i - Main Forum
3
07-28-2010 02:17 AM


Thread Tools
Search this Thread
Quick Reply: Wiring diagram is wrong? Or is my harness the issue?


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.