F4i - Main Forum Main F4i discussion board

Not priming

  #1  
Old 04-05-2012, 12:00 PM
Junior Member
Thread Starter
Join Date: Apr 2009
Posts: 12
Default Not priming

I have a 01 f4i and last year my rectifyer blew out. I baught a new batery and I could still start the bike with the full batery. After a while the bike stopped priming when I try to turn it on. My question is would that be related to the need of a new retifyer or is there a bigger issue. I did just buy a new retifyer but havn't put it on yet. Is there anyone who has knowledge of this issue? Also if you know of a good place to buy a new undertail that would also help. I don't have a battery tray with the one I have, but I did make one and don't really like the idea of having an aluminum tray doesn't sound very safe any sudgestions would help thanks
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kopi Ko
F4i - Main Forum
7
07-24-2013 08:32 PM
iRIDE_F4i
F4i - Main Forum
8
05-01-2011 11:09 PM
ispidey
General Tech
2
10-22-2007 07:14 PM
900rr_Guy
CBR 900RR
2
05-18-2007 06:00 PM
03bladeRunneR
CBR 954RR
0
03-21-2006 01:47 AM


Thread Tools
Search this Thread
Quick Reply: Not priming


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.