F4i - Main Forum Main F4i discussion board

New Fuel pump???

  #1  
Old 05-28-2010, 09:01 PM
vaa
vaa is offline
Junior Member
Thread Starter
Join Date: Jun 2009
Posts: 23
Default New Fuel pump???

I have a 2001 F4i that I'm building up as a streetfighter, track, frozen lake and loaner/beater bike. I tried to start it the other day and it would not start. It cranks and cranks but won't fire. I got a FI code of 9 which is a connecter on the air box if I'm remembering correctly (IAT Sensor). I haven't had a chance to look at it further to trouble shoot it but I think that there is also something going on with pump. I've had the bike for about a year and it did start and run when I first got it but it needed a new Radiator and fan. It sat with a little gas in it for that year. I started to work on the bike again last week. I got the Rad and fan installed the other day so I tried to start it and ran like crap. I put stabil and fresh fuel in it thinking that would help but it won't start now. If I recall correctly the fuel pump priming was pretty loud. It sounds really weak. Like it's clogged or dyeing. I think I replaced the solenoids in the tail with ones I got with a new to me wire harness. I think one of those is a fuel pump noid. Maybe I'll replace them back to the original noids. I guess it is also possible that something got pinched when I had the tank up. There are also a bunch of blown fuses that I have to replace in the fuse box.

I know, I know. Wrap it up already. I think I have a plan of attack but I want to make sure I'm not missing something super simple that could be the cause.

Here is a little history about the bike:
The bike was crashed and then parked for about a year and a half

The bike started when I took delivery of it. The Radiator was twisted and the fan and bracket were wedged so they could not work. I too off the front plastics and light housing off. The bike had an undertail that I converted back to stock tail light and stalk rear blinkers. Brake lever was snapped so I replaced the front master with my extra 05 GSXR 1000 one. Now the tail light thinks the brakes are always being pressed(another issue for another thread). The front end has stripped wire still exposed waiting for the front light assy and screen.

Thanks for your help.
Victor
 
  #2  
Old 05-29-2010, 07:49 AM
jonld's Avatar
Senior Member
Join Date: Mar 2005
Location:
Posts: 647
Default

Take the tank off. Drain the fuel out of it and flip it over. Take the nuts off the circle plate on the bottom and pull the fuel pump out. It will be surounded by what looks like a brillow pad or steel wool. Anyways, the fuel pump has a little screen on the suction side aswell as a metal fuel filter. I dont know if you can get the screen new, I just clean it. The fuel filter can be replaced. If the pump will still prime you can probably clean those parts and it will work longer. With it being clogged up it will put a extra load on the pump and cause it to burn up.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kopi Ko
F4i - Main Forum
12
11-18-2017 11:46 AM
Rockshoxtora
General Tech
1
08-12-2010 03:58 PM
Fool
F4i - Wanted
3
05-10-2010 02:05 PM
zblad
F4i - Main Forum
3
12-05-2008 01:14 AM


Thread Tools
Search this Thread
Quick Reply: New Fuel pump???


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.