F4i - Main Forum Main F4i discussion board

Low fuel indicator not working

  #1  
Old 02-03-2015, 11:49 AM
ny rider's Avatar
Senior Member
Thread Starter
Join Date: Oct 2011
Location: Miami
Posts: 107
Default Low fuel indicator not working

Hi Guys,
I have a problem with my 2006 F4i.
My indicator comes on when I start the bike and it does the self check then goes off. The problem is, it WILL NOT come back on even when the fuel is low. Found that out the hard way. Is it the sensor? Can it be replaced? or is it part of the fuel pump assembly?
I know for a fact its not the fuel, I actually rode the bike till it was dry in hopes that the bars would show up.
 

Last edited by ny rider; 02-03-2015 at 02:06 PM.
  #2  
Old 02-08-2015, 02:13 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,001
Default

I would pull the pump and make sure nothing is stuck or something. I honestly am not sure if its separate, on cars its always part of the pump. On my 06 I've gone till the bars were all blinking empty then another 40 or so miles, so its not like the thing is accurate to begin with lol
 
  #3  
Old 02-09-2015, 09:31 AM
ny rider's Avatar
Senior Member
Thread Starter
Join Date: Oct 2011
Location: Miami
Posts: 107
Default

Thanks bored, I will try that.
I know its not very accurate, but the warning beats getting stranded which has happened to me already.
 
  #4  
Old 02-15-2015, 07:35 AM
IDoDirt's Avatar
Retired Super Moderator
Join Date: Aug 2006
Location: South Florida, USA
Posts: 3,187
Default

There is a procedure for checking the operation of the Fuel Reserve Sensor. It's on page 19-18 of the shop manual. Here's what it says.
  1. Disconnect the fuel reserve 3P black connector and short the wire harness side of the connector Brown/Black and Green/Black with a jumper.
  2. Turn the ignition switch to ON and make sure the fuel reserve indicator comes on with the side stand retracted (UP).
  3. If it comes on, replace the fuel pump
  4. If it doesn't come on, check for an open or short in the wiring harness.
 

Last edited by IDoDirt; 02-16-2015 at 02:43 PM. Reason: Spelling
  #5  
Old 02-16-2015, 11:28 AM
ny rider's Avatar
Senior Member
Thread Starter
Join Date: Oct 2011
Location: Miami
Posts: 107
Default Thanks

Originally Posted by IDoDirt View Post
There is a procedure for checking the operation of the Fuel Reserve Sensor. It's on page 19-18 of the shop manual. Here's what it says.
  1. Disconnect the fuel reserve 3P black connector and short he wore harness side of the connector Brown/Black and Green/Black with a jumper.
  2. Turn the ignition switch to ON and make sure the fuel reserve indicator comes on with the side stand retracted (UP).
  3. If it comes on, replace the fuel pump
  4. If it doesn't come on, check for an open or short in the wiring harness.
Thanks idodirt,
I really need a shop manual.
 
  #6  
Old 02-16-2015, 02:43 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,001
Default

You can download it from the owners manual links thread on this forum in general maint.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
emefef
CBR 600F4
6
09-11-2012 02:58 PM
dylan
General Tech
6
03-06-2010 06:47 PM
lax4ever
F4i - Main Forum
9
08-31-2009 07:22 PM
mxpunk
F4i - Main Forum
5
10-13-2008 10:43 PM
jimmy_gr
General Tech
14
12-15-2005 03:53 AM


Thread Tools
Search this Thread
Quick Reply: Low fuel indicator not working


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.