F4i - Main Forum Main F4i discussion board

HID install...

  #1  
Old 07-08-2009, 09:31 AM
nickpriv's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: georgetown, MA
Posts: 40
Default HID install...

Hey guys, I know I may be posting this in the wrong spot (if so mod's can move it) but I'm looking for the best chance to get a quick response. I just got my HID's from DDM Tuning and I'm in the process of putting them on. There doesn't seem to be too much room to mount the ballasts and I was wondering where you guys put them. Also, the end pieces of the wiring that are supposed to be connected to the battery terminals has no chance of gettin the screws through them, are you supposed to just tighten the screw tight enough that they will stay? I know I probably sound pretty electrically incompetent (which is somewhat true) but any help you guys have would be great. Thanks
 
  #2  
Old 07-08-2009, 01:32 PM
Showtime_III's Avatar
Senior Member
Join Date: Jul 2008
Location:
Posts: 124
Default

i have read that you have to tighten the screws to make them stay. i dropped mine off at a shop to install along with the rest of my bikes makeover
 
  #3  
Old 07-08-2009, 01:35 PM
Showtime_III's Avatar
Senior Member
Join Date: Jul 2008
Location:
Posts: 124
Default

and i got mine in from ddm tuning too

i went with 35w 6000k. what about you?
 
  #4  
Old 07-08-2009, 02:59 PM
Senior Member
Join Date: Jan 2009
Location: Florida
Posts: 184
Default

What end pieces of wiring?

I have the DDM Tuning HID's too (6000k, 35w, putting them in now as well), but I'm unsure of what you are talking about.

+1 to finding a place to mount them, though.

I've been thinking about doing it this way ( https://cbrforum.com/forum/f4i-main-forum-11/my-first-mod-done-45312/ ), but I really don't feel like taking off the front fairing.
 
  #5  
Old 07-08-2009, 07:54 PM
nickpriv's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: georgetown, MA
Posts: 40
Default

35watt 6000k here too...best visibility with some nice color too it.

The pieces I'm talkin about are the pieces of wire that need to be connected to the battery. The metal pieces at the ends of these wires have a tiny hole in them which the screw into the battery cant go through. So I'm guessing you gotta tighten the screws enough to get them to stay.

As for mounting, that link looks like a good, and probably the only really feasible way of doing it...sucks we gotta take the front fender off though.
 
  #6  
Old 07-08-2009, 08:02 PM
Member
Join Date: Jun 2006
Location: lowell ma
Posts: 64
Default

dood are you taking about the 2 wires coming out from the bulb that are black and red and has a little spade at the end?
 
  #7  
Old 07-08-2009, 08:18 PM
yog182's Avatar
Senior Member
Join Date: Dec 2008
Location: Harrisburg, PA
Posts: 513
Default

Yes if you are talking about the little spades they go down into where you head lights use to plug in. Green is ground which was black on my kit and blue was hot which was red on my lights.. I installed my HID's within 20 minutes.. I went 8k just for a touch of blue =) Post some pix and we may be able to help ya out
 
  #8  
Old 07-08-2009, 08:24 PM
nickpriv's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: georgetown, MA
Posts: 40
Default

ya i am talkin about those haha...just took the front fearing off and realized that they connect where the old ones used to (please note the comment on my first post about electrical incompetence haha) I think im gonna be all set now, thanks guys.
 
  #9  
Old 07-08-2009, 08:28 PM
Member
Join Date: Jun 2006
Location: lowell ma
Posts: 64
Default

lol..yeah i was gonna say that..well sounds like your good to go!
 
  #10  
Old 07-09-2009, 08:39 AM
nickpriv's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: georgetown, MA
Posts: 40
Default

ok one last question...seeing as the spades go into the connector right behind the bulb, what about the two fuses(?) that are in the middle of the two headlights where this guy mounted the ballasts https://cbrforum.com/forum/showthread.php?t=45312
They seem like fuses, but I'm guessing the ignitors from the HID's will take their place. Sorry for bein such a noob haha but i appreciate all of you guys' help.
 

Thread Tools
Search this Thread
Quick Reply: HID install...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.