F4i - Main Forum Main F4i discussion board

Help me out please, stranded on the road! Bike not starting

  #1  
Old 05-11-2014, 01:37 PM
Junior Member
Thread Starter
Join Date: Nov 2013
Posts: 13
Default Help me out please, stranded on the road! Bike not starting

So I started my bike getting ready to take off, idling. Then the bike just dies. When I turn the key, absolutely nothing happens. No lights come on, fuel doesn't prime, nothing. Like the bike doesn't even know I'm turning the key. I tried jumping it. The battery has juice. All fuses are all good. Could it be the ignition? I had the typical problem with the starter before, and had to resolder the wiring. But even then, the bike would respond when I turned the key. Any ideas would help me out please!
 
  #2  
Old 05-11-2014, 02:23 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,001
Default

There is a large connector in the wiring system that likes to cause problems when its wet out....either way you probably aren't going to be fixing it on the side of the road
 
  #3  
Old 05-11-2014, 06:29 PM
"A"'s Avatar
"A"
"A" is offline
Senior Member
Join Date: Apr 2013
Location: Phila. PA-Bklyn, NY
Posts: 215
Default

Check 20A main fuse? that's not in the fuse box.
 
  #4  
Old 05-12-2014, 12:37 PM
Junior Member
Thread Starter
Join Date: Nov 2013
Posts: 13
Default

Originally Posted by boredandstroked View Post
There is a large connector in the wiring system that likes to cause problems when its wet out....either way you probably aren't going to be fixing it on the side of the road
Where is this connector you're talking about?
 
  #5  
Old 05-12-2014, 01:00 PM
ceebear's Avatar
Member
Join Date: Nov 2005
Location: Dumfries, VA
Posts: 82
Default

tilt sensor??
 
  #6  
Old 05-12-2014, 06:18 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,001
Default

Originally Posted by AntP1987 View Post
Where is this connector you're talking about?
Not sure, just know both of my friends with F4i's have had that connector cause their bikes to go down at some point, I've never had the problem thankfully.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NYKnick1015
CBR 954RR
24
09-08-2012 01:18 PM
ko67
F2 Tech
11
12-17-2010 01:58 PM
ajzcamaro
CBR 600F3
3
01-29-2010 10:10 PM
Jr_toy
CBR 900RR
10
09-14-2009 02:56 PM
imran
CBR 600F3
3
10-05-2005 09:35 PM


Thread Tools
Search this Thread
Quick Reply: Help me out please, stranded on the road! Bike not starting


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.