F4i - Main Forum Main F4i discussion board

in dire need of an f4i electrical guru!!!

  #1  
Old 07-23-2010, 05:24 PM
Member
Thread Starter
Join Date: Jul 2010
Posts: 45
Default in dire need of an f4i electrical guru!!!

huge problem with my bike that none of us can figure out, i was rebuilding my after a wreck and i had the bike running and now somewhere in the build it has stopped working. the fuel pump will not prime and everything else seems to be ok. i do not have any front turn signals plugged in though! but my headlight( low and high) beams come on, it cranks over, only neutral light and red light appear on guage cluster, brear blinkers work, horn works. but will not start. ive changed out the 3 relays under the tail section, all fuses are good, kill switch is not on and ive tried rocking it back and fourth a million times, wiggle pulled and pushed and clean all my wire connections on front of bike, bypassed the bas and kickstand switches yet no luck. this thing has got me pulling my hair out! any help would be great
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
FireBlade910
CBR 954RR
7
07-28-2015 10:57 PM
donnygeewebb
F4i - Main Forum
9
04-03-2012 11:24 PM
honda f4
General Tech
3
01-27-2009 01:57 AM
bakesteak
CBR 600F2
2
07-29-2008 02:09 PM
deerslayer
CBR 600F2
3
01-28-2008 07:00 AM


Thread Tools
Search this Thread
Quick Reply: in dire need of an f4i electrical guru!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.