F4i - Main Forum Main F4i discussion board

Dies after warm up. Fuel pressure issue?

  #1  
Old 07-12-2014, 12:16 AM
rikubot's Avatar
Junior Member
Thread Starter
Join Date: Mar 2010
Location: colorado
Posts: 24
Default Dies after warm up. Fuel pressure issue?

Hi guys. I had the typical FPR issues, replaced it, and still same problem. Runs good cold and idles high, warms up and then slowly dies out. The only change I can get is when I unplug the smaller hose from the FPR. AfTer doing so, the idle seems to run back at normal idle and it sounds and throttles good. No idea why unplugging it would let it idle normally. Seems to get fuel and air and spark FML it's killing me. Someone please help, I'd be eternally great full. Thanks for any help, sincerely Mike.
 
  #2  
Old 07-13-2014, 05:08 PM
Senior Member
Join Date: Jul 2008
Location: Mesa AZ
Posts: 2,001
Default

Perhaps the fuel pump is going bad? That's a pretty weird problem. Removing the vaccum line would make the regulator stop regulating basically. If the pumps going bad and you remove the regulator maybe thats allowing enough pressure for the bike to run. Time to hook up a fuel pressure guage.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Frosty600
F4i - Main Forum
0
07-09-2012 10:10 PM
Imakeu Randy
CBR 600F4
5
06-24-2012 07:33 PM
krumper11
General Tech
3
01-28-2012 10:36 AM
cbrrnewbie74
CBR 900RR
1
10-03-2010 08:46 PM
CatDaddy512
CBR 600F4
2
09-10-2009 01:14 PM


Thread Tools
Search this Thread
Quick Reply: Dies after warm up. Fuel pressure issue?


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.