F4i - Main Forum Main F4i discussion board

bike died and now will not start, help

  #1  
Old 05-27-2010, 12:49 AM
Junior Member
Thread Starter
Join Date: Apr 2010
Posts: 28
Default bike died and now will not start, help

I rode home from work, probably 15miles, and I was pulling in my driveway and it died, it turns over but will not fire up, just cranks. I sprayed a little starter fluid in the intake and it ran a few seconds, so im thinking the fuel pump or something that controls the pump isnt working, I also dont hear the pump run like it always does when I turn the key on. In a possibly related note the best milage ive gotten on it is 32mpg

I checked the fuses under the seat, just wondering if it could be a relay, ecu, or pump problem
 
  #2  
Old 05-27-2010, 09:14 AM
Member
Join Date: May 2010
Location: Wi
Posts: 50
Default

If you aren't hearing the noise when you turn the key on, then it seems logical to conclude the pump isn't running.

I would start with checking fuses first.
 
  #3  
Old 05-27-2010, 10:08 AM
Junior Member
Thread Starter
Join Date: Apr 2010
Posts: 28
Default

I checked all the fusesunder the seat, next to the battary. Are there any more fuses or relays that control the fuel pump somewhere else on the bike?
 
  #4  
Old 05-27-2010, 11:11 AM
IIRyan's Avatar
Member
Join Date: Aug 2009
Location: Ontario, Canada
Posts: 31
Default

I had a similar issue not too long ago...you should be able to find the thread somewhere (F4i Fuel Pump Issue) - it's full of great suggestions. My bike ended up having a wire grounding out that lead to the fuel pump.

EDIT: https://cbrforum.com/forum/showthrea...uel+pump+issue
 
  #5  
Old 05-27-2010, 01:51 PM
Junior Member
Thread Starter
Join Date: Apr 2010
Posts: 28
Default

I saw in that discussion, something about if the head light was on or not and if the turn signal indicators were on, my hedlight isnt on when the key is and the turn signal indicators are on when the key is, could this mean anything
 
  #6  
Old 05-28-2010, 01:05 AM
Junior Member
Thread Starter
Join Date: Apr 2010
Posts: 28
Default

I even unplugged everything in the front fairing with lights, and bank angle sensor, still wont run, or does the BAC still have to be connected to run?
 
  #7  
Old 05-28-2010, 08:18 AM
Member
Join Date: May 2010
Location: Wi
Posts: 50
Default

I'd have to double check, but I think my headlight is on when my key is on, and goes out when I start cranking the engine.

I'm also not 100% on the bank sensor, but I seem to remember something about it in a stunt forum, saying that you can't just unplug, you have to jumper 2 of the wires together.
 
  #8  
Old 05-28-2010, 11:45 AM
R Dub's Avatar
October 2011 ROTM
Join Date: Feb 2009
Location: Burbs of Chicago
Posts: 1,340
Default

Check you front headlight harness where it plugs into the main harness down by the left air intake. Seems to be a fairly common problem that they get corroded and then the bike won't run. Took me 2 weeks to figure it out on mine.
 
  #9  
Old 05-28-2010, 12:36 PM
IIRyan's Avatar
Member
Join Date: Aug 2009
Location: Ontario, Canada
Posts: 31
Default

Originally Posted by R Dub View Post
Check you front headlight harness where it plugs into the main harness down by the left air intake. Seems to be a fairly common problem that they get corroded and then the bike won't run. Took me 2 weeks to figure it out on mine.
That would be my guess.
 
  #10  
Old 05-29-2010, 02:40 PM
Junior Member
Thread Starter
Join Date: Apr 2010
Posts: 28
Default

Yeah, it died turning a corner by my house, the suspension is set pretty stiff so maybe a bump messed with the connection somehow, and shut the pump off. The headlight harness was connected to the main harness pretty good thou, not loose or anything. I will inspect the connector and and plug it back in and see it that helps, also gonna test the plug for the pump is its even getting juice
 

Thread Tools
Search this Thread
Quick Reply: bike died and now will not start, help


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.