F4i - Main Forum Main F4i discussion board

04 cranks once but won't fire

  #1  
Old 01-24-2015, 02:55 PM
Junior Member
Thread Starter
Join Date: Jul 2012
Posts: 13
Default 04 cranks once but won't fire

Bike has been sitting for a couple years. I changed the fuel pressure regulator 2 years ago but have only added about 700 miles on it since. I stored it for the last 11 or 12 months with a full tank of gas and stabilizer in the tank. Yesterday I drained the tank and refilled with fresh gas. I can hear the fuel pump priming but it will only crank one time and then nothing happens. Battery is 2 years old, I also recharged it yesterday.

Cranks once, dies, won't continue cranking until I reflick the ignition switch. But I think doing that over and over again with a 1 time crank is a bad idea.

Any ideas?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
703patrick
CBR 600F3
2
03-25-2014 06:19 PM
rocco787
CBR 600F3
1
07-13-2012 10:59 AM
bman1592
F4i - Main Forum
3
06-15-2012 04:21 PM
Matt5606
F4i - Main Forum
6
11-28-2010 03:01 PM
elitepdr08
General Tech
4
06-23-2008 11:00 AM


Thread Tools
Search this Thread
Quick Reply: 04 cranks once but won't fire


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.