1987 hurricane 600 clutch wonít engage - CBR Forum - Enthusiast forums for Honda CBR Owners


CBR 600F 1987 - 1990 CBR 600F Forum

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-06-2018, 07:05 PM
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 3
Default 1987 hurricane 600 clutch wonít engage

I recently replaced the stater on my 1987 Honda hurricane 600. After changing the oil and putting everything back together the clutch handle was super loose and wouldnít engage. Iíve taken it apart and check the return spring was still there, I also replaced the clutch cable and tightened it and nothing. Please help itís bike season and Iím without.
Reply With Quote
  #2  
Old 04-07-2018, 11:49 AM
drakito's Avatar
Senior Member
 
Join Date: Oct 2006
Location: Southern Utah
Posts: 621
Default

Have you downloaded the service manual yet? It goes over adjusting the cable after removal. You have to loosen it so much that it will do nothing if you took it off. Go through the manual and it will show you if you mounted the cable mounts in the right place and how to adjust it correctly.
Reply With Quote
  #3  
Old 04-07-2018, 04:50 PM
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 3
Default Answer yes

Quote:
Originally Posted by drakito View Post
Have you downloaded the service manual yet? It goes over adjusting the cable after removal. You have to loosen it so much that it will do nothing if you took it off. Go through the manual and it will show you if you mounted the cable mounts in the right place and how to adjust it correctly.
yes I have adjusted it correctly it feels like itís not grabbing anything inside the clutch cover Iíve taken it off A few times now it feels like itís not connected somewhere but I donít know where because everything looks right
Reply With Quote
  #4  
Old 04-09-2018, 09:06 PM
drakito's Avatar
Senior Member
 
Join Date: Oct 2006
Location: Southern Utah
Posts: 621
Default

Is the clutch button still in the case half? You know, what the cable actuates to push on the clutch hub?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
CBR600 F4i 2006 clutch wont engage after installing new clutch kit Insurgence F4i - Main Forum 2 06-10-2017 03:30 PM
Clutch won't Engage/Disengage!!!!! gtogottogo CBR 600F 4 02-04-2009 10:20 PM
HELP! F2 won't engage neutral if the engine is ON! gnuwolf CBR 600F2 4 08-13-2008 07:02 PM
Clutch will not dis-engage dlinzy General Tech 3 03-10-2008 10:06 PM
Clutch won't engage J_DOVE F4i - Main Forum 0 04-11-2005 11:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 04:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.